HTTP port 80 fails

Hi all,

I’m working with a PortServer TS 4 MEI, and have a linux terminal connected to serial port 4. I’m streaming data over the serial port, and have the port profile configured to ‘TCP Server’ in ‘raw’ mode.

On the client side, I’m trying to read the data stream by connecting to the TCP socket on port 2104 (the base is 2000).

I’ve run into two issues:

  1. Instead of listening on 2104, it listens on 2604. The web interface reports that TCP raw connections should connect to 2104, but a port scan using nmap shows that 2604 is listening. Is this normal behavior?

  2. Upon trying to connect to TCP port 2604 and read the data stream originating from the serial port, the web interface stopped responding on port 80. Up until that point, I was able to use the web interface for configuration, etc., but no longer can.

I then ssh’d into the PortServer and issued:

set netports http=8080

to see if the web server would listen on another port. It can, and it does now. However, I would really like it to stay on the standard port 80.

In the event that there may be a firmware bug, I upgraded the firmware using:

boot load=

where I had downloaded the latest firmware and dropped it into a tftp server on the linux machine. This process worked well and the firmware was replaced. However, the same behavior persists: http works via port 8080, but http via port 80 just hangs (after I issue: set netports http=80 and then reboot).

I also tried:

boot action=factory

to reset the Port Server to factory defaults, with no luck on fixing the http/port 80 problem.

Am I missing something basic here?

Has anyone else experienced this? A search of the forums shows other http issues, but not this one.

Thanks for any help you can give in advance,

I have not heard of this behavior. It would be interesting to see the configuration on the unit.

> Am I missing something basic here?

Yup, I was missing something basic =). It hadn’t occurred to me that this was a client side issue - the browser. After closing Firefox and re-opening, connecting to port 80 worked just fine. Perhaps I had a session caching problem or something.

Also, I am now streaming over TCP port 2104 (not 2604). I don’t know why it reports port 2604 being open during a portscan rather than 2104. However, after a few more tries with my client code, connecting to 2104 worked fine.

Thanks for responding - I think these were just naive mistakes on my part.


2604 would be the SSH equivalant serial port for port 4 on the unit, with TCP base socket of 2000.