Is it possible to use my XBee S2C as an end device in a ZigBee2MQTT network?

I’ve spent a couple of hours experimenting with a couple of XBee ZigBee modules, but do not seem to be able to make them part of a ZigBee2MQTT network.
I can’t get either of the modules to join the network or be seen by ZigBee2MQTT at all.

I think that the primary reason is that the firmware on them is not compatible with the ZigBee HA (home automation) protocol.
There is some information here about setting up an XBee module for HA at:
… but it is for different modules - not the XBee S2D ones I’ve got here.
No explanation is provided as to what change each setting makes to the operation of an XBee module.

In fact, it seems that the S2D modules in my possession are not now recommended for new designs by Digi.

Even if I could get either of the XBee ZigBee modules to join the network, I don’t know if I could do anything with them apart from acting as a ZigBee router, e.g. to extend the range.
In addition, I’m not sure if the right kind of features would be exposed to actually send data to it – this is where my lower level zigbee know-how is not sufficient.
Data would need to be exchanged between the ZigBee Module and the end-point device.

I seem to be stuck.

Any advice with regard to how to get zigbee2mqtt to working with a XBee ZigBee module would be welcomed.

In particular, please can Digi or anyone reading this confirm what equivalent settings at:
… need to be applied to my XBee S2D modules to get them to work as end devices with a ZigBee2MQTT network?

Yes you should be able to. You just need to adjust the settings on the XBee to use the HA profile. That means you change the settings such as ZS EE, KY etc for the Home Automation values.

The settings at are for ALL Digi XBee Zigbee devices.


I tried following the instructions in the HA link to get my S2D modules to work with Zigbee2Mqtt, but couldn’t get them to join.

I’ve recently tried with XBee3 modules (XB3-24) and they connect fine.

As yet, I don’t understand why the S2D modules don’t work, but the XBee3 are probably the ones to use for new development work anyway.