My coordinator is not able to find the sub modules.

My coordinator is not able to find the submodules, I have set the parameters according to the ones mentioned in the official tutorial but it is not able to discover remote devices. I set the updated firmware and set the values to default before setting and writing the parameters.
I checked and the router and end device do not get the OP ID in the operating network parameters section.
I have also tried setting the parameters to default and repeating them many times and also tried with older firmware versions as well.

Restore all radios to defaults. Set the CE on the Coordinator to 1. Issue an ATNR0 on each of the nodes starting with the coordinator. Each node should start flashing once associated.

Hi, thank you so much for the reply. I set the values to default, write to devices, then set the CE to 1 on the Coordinator. Then I wrote ATNR0 on all the devices starting from COORDINATOR. Then I put the rest of the parameters as mentioned in the and wrote to the devices. But still the devices are not getting on the same network. I would be very grateful if you can help me solve this issue because I can find any help anywhere.

Try writing the settings first. Then issue the NR0 command.