'Name not registered' error in iDigi Platform Web Service Response

Hi Forum,

I am trying to send commands to an XBee Series 2 ZB module from the IDigi Developer Cloud via a ConnectPort X2. The ConnectPort X2 has the xig software onboard. The python script response from the Web Service returns Name not registered.

I can ping developer.idigi.com from the ConnectPort X2 using both the URL name and the IP address. The ConnectPort also shows as connected on the XBee network tab of the iDigi Device tab. Both the CP X2 and the XBee ZB node show on the XBee Networks tab.

The CP X2 device ID is …7E37. The XBee ZB module hardware address is the … :a1! string.



        Name not registered

The following files are loaded on the CP X2:
_xig.zip, xig.py, xig_config.py. xig.py is set as an autostart file.

Thanks for any assistance you can lend.

Hello Curtis,

The error Name not registered means that there is not any RCI callback registered waiting for the target name “xig” when executing the RCI command .

This means that for some reason the xig callback got unregistered. Looking at the code this only happens when main ioloop is interrupted, you may be getting an exception while setting it up. Could you verify if you get any error output in the logger?


Thanks for your response! What logger are you referring to? There is no option in telnet commands to enable logging on my ConnectPort X2 if that is the device log you are asking about.



I don’t know where/what is the log. I know there is a log because XIG executes this on startup:

import library.logging_stub #@UnusedImport
import logging
logger = logging.getLogger()
handler = logging.StreamHandler()
formatter = logging.Formatter('%(name)s - %(message)s')

create our logger, setup log levels:

logger = logging.getLogger(“xig”)
logger.info(“%s v%s starting.” % (NAME, VERSION))

And it logs information continously:

logger.debug(“No xig_config.py found, using default config”)
logger.info(“Starting scheduler…”)
… etc

May be it is a file?

I’m getting the same error. I changed the ‘<’ to < and ‘>’ to > but still got the same error.
I tried
Both give the same error.
I found the log folder and there are 4 files there:
In what log should I look for an event showing where the callback got unregistered? Also how will it be worded in the log?

Found my issue. I was using the wrong request. Copied Robert’s and it works now.