Need help troubleshooting Digi AccelePort Xem ISA

I’m trying to set up some old BBS software strictly as a hobby type of thing. I want to be able to connect to the BBS with regular telnet.

To do this, I’m currently using a TS2 MEI PortServer. The Ethernet cable goes in one side, and an RJ45 to DB25 cable goes out the other and connects to the computer. Thanks to previous help on this forum, I’ve got that part working.

This particular BBS software supports up to 16 connections. I don’t necessarily need or even want to get all 16 connections working, but I do want more than 2.

I found a brand new, still sealed in the box, Digi ISA AccelePort Xem Host Adapter + 8 port Digi 8EM AccelePort DB25 Serial Adaptor (P/N 50000478) on eBay, so I grabbed it up.

The computer I installed the ISA card in has very little hardware in it, so I didn’t have any problems with conflicts. I ran the DIGIMAP.EXE DOS program and it found plenty of available memory space. I then ran the UD-RISC.EXE program, and followed the directions in the printed manual to configure the card. Again - no problems, and the card passed all the tests.

The problem I’m having is that I can’t connect to the BBS when going through the Digi BOX/ISA card, but I can connect if I just go through a regular COM port. So I know the PortServer part is working, but something isn’t working somewhere between entering the 8 port DB25 Box and going into the computer.

My suspicion is that it’s I/O port related. The ISA card has 4 dip switches (though only the first 3 are used.) The default is that they are all on, which the book says is 324h. When I go to the BBS setup, it wants the I/O port in HEX, ranging from 0000 to FFFF. Normally I would use 3F8 or 2F8 for COM1 or COM2 respectively, but the Digi ISA card only allows 7 options which are:

[ul][li] 324h[/li][li]304h[/li][li]224h[/li][li]204h[/li][li]124h[/li][li]114h[/li][li]104h[/li][/ul]

Is there a DOS-based terminal program I can run that will let me listen to 324h for raw input/ouput so I can at least determine that data is flowing through? Or does anyone have an idea of how to troubleshoot this?


This post hasn’t been approved yet, so I’ll add to it now before anyone sees it.

I may have found part of the problem, but I’m out of time for the day and can’t mess with it any more. So I’ll have to check it tomorrow or the next day.

I thought the ISA card was configured through the UD-RISC.EXE program and that was it. But after a bit more looking, it appears there’s an MS-DOS 6.22 driver. The package doesn’t appear to have that driver with it, so I didn’t think it needed one.

I took a quick look at the DOS driver I found here:

And it has a lot more options. I’m not sure if the card requires a line in CONFIG.SYS, or if you just have to run the EXE to set up the options, and then it writes the options to the card.

Either way, it gives me something new to try when I get the time.

Still no luck with this after working with the DOS drivers. This PDF DOS manual says that you need to load two things in your CONFIG.SYS. (The Xem System portion starts on Page 30, and the CONFIG.SYS info is on Page 35 and 49.)

It says you need to load XEMDOS5.SYS (which I’ve done), and XEM5INIT.SYS. But that second driver is no where to be found in the download. The XEMDOS5.SYS is actually created by the config program. There is a file called XEMDOS5.PGM which is the original driver, but you have to run XEMCFG.EXE to set up the driver. Once you have set up the driver, it saves a copy of XEMDOS5.PGM as XEMDOS5.SYS

But it doesn’t create XEM5INIT.SYS. A google search for XEM5INIT.SYS only returns 1 link, which is the PDF.

Does anyone know how the DOS drivers are set up?

Yes, you will need a driver which will create COM ports that should work in the same way as the built in COM port. The latest DOS driver is here:

1 Like

Thanks for the reply. I should have mentioned in my EDIT that that is the DOS driver I ended up trying out. I feel like it got me to the next step, but that 4001480d.exe seems to be missing a required driver.

In my follow up message, I pointed out a PDF that talks about adding XEM5INIT.SYS to your CONFIG.SYS, but XEM5INIT.SYS is no where to be found in that package. Click here to see the PDF ( and look at pages 35 and 49.

So … I’m not sure how to proceed without the XEM5INIT.SYS driver?

I have no knowledge of DOS implementation, however the following might be helpful:

Thanks for the link.

Regarding the first bullet point about the DOS device driver not being loaded, this is what I was referring to in my previous posts. The documentation says there are 2 .SYS files, but the file I downloaded from the digi site only has 1 of them? I am loading XEMDOS5.SYS per the documentation, but the XEM5INIT.SYS is no where to be found.

Regarding the second bullet point, I am definitely not running under Windows. The computer is an old 486 and I’ve fully dedicated it to plain DOS.

Regarding the third bullet point, the application (which is Major BBS by Galacticomm) gives you the option to specify the I/O port. So it’s not hard coded to a specific I/O such as 3F8 and 2F8 like some of the other BBS’s were.

I think I found the appropriate driver:


Hope this helps.

Wow, thanks. I don’t know how you found that. When I did a search for XEM5INIT.SYS, it just came back with a PDF file.

I’ve spent the last couple of hours messing with it, and unfortunately it still isn’t working. I just don’t understand. It’s such a simple thing.

I put a copy of TELIX on the computer so I could test the connectivity without going through the BBS. When I have the TS2 MEI PortServer going to COM1 or COM2 on the computer with standard IRQ’s and I/O ports, I am able to telnet into the computer and see it come through in TELIX.

When I plug the TS2 MEI PortServer into the 8 port Box (which then plugs into the XEM card), nothing ever works. TELIX reports that it can’t initialize the port and when I try to telnet in, it’s completely dead.

I tried toggling the dip switches to use different I/O ports. I knew it wouldn’t help because the drivers load just fine with the default I/O port, but I figured I would try it anyway. And of course it didn’t make a difference.

I just don’t understand the problem. The software testing tools say all tests pass, when I plug in the DB25 loopback adapter, the software says the loopback test passes, the system can clearly tell when the 8 port box is or is not plugged in. If I unplug it and reboot, the drivers notify me there are no available ports when the computer comes back up. And when I plug it back in and reboot, the drivers say 8 ports have initialized successfully.

But when I try to actually communicate, everything acts like it’s dead.