Need to restart the computer while xbee plugged in? [SOLVED]

** Edit: The problem was the Wacom tablet driver conflicting with the Sparkfun Explorer. I uninstalled the tablet driver and it works perfectly.

The problem:
If I plug my xBee after my computer boots up, it doesn’t show up in the serial list. However, if I plug it and then turn on the computer, then I see it in the list, however, if I unplug the xBee and replug again then I can’t see it in the list again. Everytime, I need to restart my computer with the xBee plugged in beforehand.

I didn’t do any update or nothing changed in my system. Short time a go, no matter when I plugged in my xBee, it was always showing up.

  • I connect my xBee through Sparkfun xBee explorer.

What may cause this problem? Any suggestions?


This sounds like it is an issue for either Sparkfun as it is their board or your operating system manufacture as it is not populating the USB components properly.

No, actually it was Wacom tablet driver somehow conflicting with the explorer. I uninstalled the tablet driver, and now it works perfectly!