Portserver RealPort com settings change by themselves

Hi, I have a number of Digi Portserver TS3+M units where the com port settings keep changing randomly. Often changing to 1200 baud 7N1.

We’ve just added a new laptop to the network that runs Windows 7.

We had this problem once before and I remember we had to change something in the Windows OS so it doesn’t scan ports??

Something like “Do not scan ports for modems” or similar?

Can anyone tell me where in windows 7 this or the correct setting is that stops the OS from scanning the Digi mapped in ports and stuffing up the setting at boot?


I don’t recall the “don’t scan ports for modems”, however I assume you are using Realport. Is that the case? The TS will use whatever your application will want to use for port settings. Is your app trying to use 1200?


No, it’s an effect of windows when a machine is booted it scans things that are plugged in and this can cause the corruption of the comm’s setting in the Digi device.

We went through this about 2 months back and I found the solution somewhere but can’t remember where to look on the PC to set it again.

It’s a box you tick off in the Windows system settings that stops the scanning from happening and the corruption of the comms settings.

OK I found it on an old Win XP machine.

I’ll document it here and then look on the Win 7 machine which will be different because Microsoft love changing things to confuse people! :wink:

In device manager.
Under Multi-Port Serial adapters.

  • Portserver TS-3+M
    Advanced tab, then properties button.
    Click Port #1, go to Advanced tab.
    Under Driver Settings.
    Click “Do Not Scan for Modems on Boot”

Do this for all other ports as well.

This stops the problem of windows corrupting all the Comms settings of the Digi device when windows boots up.


This issue is now back under Windows 10.

Changing the option in the device manager settings for this latest OS (Win 10) to disable “Do not scan for Modems on Boot” no longer solves the problem.

The Port Server configs will all reset to 1200-7N1 when a Win 10 machine is first booted.

how to disable Windows not to scan modems (or for mouse) on boot, see: