The baud rate of PortServer TS4 ME is automatically changed.

I have connected a Digi PortServer TS4 MEI to an Multitech Modem ZBA via RS232.

Server----TS4[Port1]-----Multitech Modem ZBA-----PSTN
MEI[Port2]-----NEC Aterm IT21----------PSTN

Set the baudrate of Port1, Port2, Port3, and Port4 to “115200” and save it.
(115200, 8N1, no flow contro)
However, Baudrate other than Port2 after a while change into 1200.

I’m not sure whether the problem is on the Digi side.
What should I do to solve this problem?

1 Like

It’s because you have RealPort installed on a PC. When Windows machines start up, they like to iterate through all the serial ports checking them at different baud rates for attached devices. The last baud they try is 1200.

Finally, if you want to stop windows from doing this, there is an option in the RealPort driver itself called Do Not Scan Modems on Boot, check that. It can be found under: Device Manager -> Multiport Serial Adapters (select yours and properties) -> Advanced -> properties -> select your Port on the left -> Advanced -> Under Driver Settings. Details can be found in the .chm file that comes with the RealPort driver zip file.

1 Like

Thank you thank you. This was driving me nuts.