PortServer TS 4 W: 2-wire half-duplex device


I’ve just started working with the PortServer TS 4 W and have been able to successfully communicate with a RS-232 device over our ethernet network.

What I’m trying to do next is to communicate with a RS-485 2-wire device – but I’m unable to do so - no data is coming back or seems to be received by the device.

I configured the DIP switches for RS-485 half-duplex with termination. Without termination, the data is echoed back to me.

The RS-485 2-wire device is a robot servo motor with a D- & D+ with power and ground.

I wired my robot servo motor according to the table on page 111 in the TS PortServer manual for 485 2-wire mode
, i.e. D- to pin 2 and D+ to pin 6. Pin 4 CGND and Pin 7 SGND were tied to the ground from the power supply for my servo motor. I’ve also made sure that my baud rates were set correctly too.

I feel that I may be missing something.


One thing that comes to mind right away is the pinout. Digi uses a 10-pin RJ45 connector on the device, not a standard 8-pin RJ45 (such as a CAT5/6 cable). If you are using an 8-pin cable, you will need to set this up slightly different. Pin 1 would now be Data-, Pin 5 would be Data+, and SG is now on Pin 6. I would check this out if you are using an 8-pin RJ45 connector.

I’m using a 10-pin RJ-45 connector that fits snuggly into the serial port interface.

Currently, I’ve been able to send data over the ethernet to the RS-485 2-wire device, but wasn’t able to receive data back.

I’ve re-wired it as: d- of the robot servo to the PortServer TxD- pin 1 and d+ of the robot servo to the PortServer TxD+ pin 5. I was only able to transmit to the motor when I connected 110 ohm termination resistor between d+ and d-.

After the transmit worked I tried connecting in RxD- from the PortServer to d- of the motor and RxD+ to d+ too, I wasn’t able to transmit data as I was before even with the transmit lines intact (as well as receive data).

Is there an “Enable RTS Toggle” setting to switch RS-485 half duplex send and receive modes automatically? The Support Wizards said there was such a setting, but they haven’t gotten back to me yet as to where I can find it. I didn’t see any mention of it in the manual, nor did I see this setting in the TS 4 W PortServer web-page configuration manager.


Log in with your browser, under Confiiguration, Serial Ports, select the port you wish to change, Advanced Serial Settings, and you should see a check box "Enable RTS Toggle. Check the box, hit the Apply button and reboot the unit.
RTS Toggle will be enabled.

Message was edited by: admin

Here’s my settings page:

Please see my screenshot.
Either you have an older legacy unit which does not support RTS or you may have to update your firmware.

Message was edited by: admin

Thanks for your responses.

It seems that the Toggle RTS option is only available when the dip switches are set for RS-232. When I switch the port to RS-485, the option disappears.

I thought I’d bring this thread back to life since I am facing the same problem.

I am trying to connect my DIGI Portserver TS-4 MEI to a serial device ROCLINK 800 using 2-wire RS-485

I am using a RJ-45 10 Pin to DB-9F Terminal Emulator Cable Crossover Cable -4’ Part number 76000645.

I have connected pin 6 of the DB-9 to the B(-) of the ROCLINK 800 and pin 2 of my DB-9 to to my A(+) of the ROCLINK 800.

I have tested the cable and pin 6 of the RJ-45 is connected t Pin 2 of the DB-9. Pin 2 of the RJ-45 is connected to pin 6 of the DB-9.

My device won’t connect. Is there something wrong with my connection?