Problem upgrading ConnectPort X4 firmware

I tried to upgrade the firmware in my X4, current version is “ (Version 82001536_E3 08/24/2009)”.

I started by upgrading the POST, now “1.1.3 (release_82001537_G)”, tried upgrading the main firmware to 82001536_G, but the X4 says “Unable to update firmware: reason unknown”. Since then I have tried to upgrade the dia package, but this did not help.

Any clues as to why this problem appears, and what I can do to solve it?

Most of my Xbee modules are upgraded to firmware 2x70, including the coordinator in the X4. I have a wall router whose Xbee is not upgraded yet since it does not work to upgrade OTA and I have not yet picked it apart.

System information:

Firmware Version:   (Version 82001536_E3 08/24/2009)
Boot Version:	 	 	1.1.3   (release_82001531_A)
POST Version:	 		1.1.3   (release_82001537_G)
Product VPD Version:	 	release_82001747_A
Product ID:	 		0x0074
Hardware Strapping:	 	0x0043

make sure that you have your python scripts stopped before updating the firmware. You should check to make sure that you have nothing running under applications->python->auto-start settings. If you do disable it and reboot the gateway then try the update again.

Thank you very much, Wingmaster1800! With your information the upgrade was easy, no problems at all.

I wish that this would be mentioned on the firmware update page , in any and all documentation, and that the older firmware would at least state the reason for the failure (or even better, handle the problem itself).

In my opinion this should be considered a bug report to Digi, who should make an effort to clarify this.

The firmware update also solved my previous problem regarding OTA fw upgrade of Xbee modules.

By the way, the Boot Version is still release A, with POST and EOS being release G. Is this a problem? Are there any updates for the Boot Version?