Problem with XBee-PRO 868 in API mode (bricked?)


I’m having a problem with one of my XBee-PRO 868 modules. The module is used in combination with a .NET Gadgeteer module.
When I try to read an AT command in API mode, I can’t get a response from the device.
However, everything worked fine yesterday and I didn’t make any changes to the application code, nor to the module’s parameters.
This problem also only appears to happen on this particular XBee device.
When I plug in another module, my application can read the “SH” and “SL” values normally.

So my conclusion was that the module must be bricked. I then tried to restore the module to its default parameters and reprogrammed the firmware using the development board and X-CTU.
I plugged the XBee back onto the Gadgeteer module, but to no avail. After a few resets on the mainboard, however, the module did respond to the AT commands.
A few hours later I unplugged the power supply and plugged it back in, but the problem seems to have come back: it’s not responding to the AT commands anymore.

It doesn’t matter what actions I perform (restoring default settings, downgrading firmware,…), the module does not reply to the AT commands.
Now comes the really strange part of the story: when I assemble an API packet in X-CTU with the module on the development board, the module will respond to the command.

So, the XBee device appears to function normally in X-CTU, but not on the Gadgeteer module.
I can’t figure out what’s wrong with just this one XBee device, as I don’t experience the problem with any other XBee device…

Does anyone have an idea that can put me in the right direction?
Or might the modem be bricked?

Thank you!

PS: the issue is urgent, because the modules are all needed next Wednesday on one of the largest festivals in Europe.

Sounds to me like a bad socket-joint, or a floating pin, or a lack of electric power.

I don’t know anything about a .NET Gadgeteer module, however the 868 PRO can require up to 800 mA of power, so perhaps the board cannot supply that much power. many small voltage regulators max out at 500mA. Also, you can’t have two 868-PRO modules within about 4 meters of each other.


I have a similar (can’t not be sure that is the same) problem. I am working with three XBP24BZ7 modules. I have a problem with only one module: it does not answer to AT commands. I am using the “AT interactive” example for programmable modules, and it works perfectly with two of the modules, but in one of them, I always have a timeout response.

This means that the secondary processor is working fine, but there should be some kind of problem with the xbee part.
I have tried to reflash the firmware with XCTU, there is no problem in accessing to the bootloader, and no problem entering in bypass modem, but when I try to reflash, the module fails, XCTU can not access to the module and at the end I have the following message: “Getting modem type…Failed to enter command mode”.

I have no problem reflashing the other two modules, so I think that there is something wrong (flash corrupt?) in my problematic module. What can be made when the Ember module does not answer?.

atterecillas, you have a ZigBee unit, not an 868 PRO.

XCTU needs to have the correct baud rates set, or you will generally get an error. So if you set the Xbee to 115kbps and leave XCTU at the default 8600, you get the failed to enter command mode error.

Thanks Lynn.

As I said, i had a similar problem with Zigbee modules, I don’t have 868 modules.

Double checked the baud rate in XCTU, but still no luck. There is no response to AT commands in one of my modules.

I will stop posting to this thread since the problem is not related to XBee-PRO 868.

Sorry all for the inconvenience.