Problems when install legacy radio firmware

When I wanted to download the firmware, this error appeared and it didn’t let me complete the download

“Error while installing legacy firmware: Connection refused: connect”

i need help please :c

I’m also getting the same error with XCTU 6.5.12

I would suggest turning off any firewalls or VPN’s you may be working with.

I did this (and also tried with the firewall on and added a rule for XCTU’s executable over all network types), but I get this error with any update attempts:
image

There are no VPNs involved with this computer or its network connection (i.e.: computer > router (NAT) > ISP).

What can be done to fix this?

This was determined to be an issue with the FTP server. It has now been fixed.

1 Like