Problems with ZigBee App. Kit

I can not stablish a serial communication with it in order to use the AT command set. X-ctu never enter in AT command mode and I can’t read firmware or test/query the modem. We have tested the three modules that comes in the app-kit and we have the same problem in all. We have tested with other combinations of bauds, parity, …, with another serial cable, in laptops and desktops with serial ports and with usb2rs232 adapters, … Never works. Also with the hyperterminal that have windows XP.

I connect the modules in DCE, DTE. I connect the RS232 to 10 pin IDC in all combination posibles.

I have tried all I know. I would very pleased if anyone can help me.

Hi Pedro,
Please tell me your X-CTU Version.

And please check as below:

  1. Connect the Red RS232 LOOP BACK Adopter which is included in the Kit.
  2. Run X-CTU.
  3. Specify the COM PORT with LOOP BACK Adopter
  4. Select Flow Control “Hardware”
  5. In terminal Tab, type some message and if it loop back, software and serial communication are good.

Please try that and tell me the reult.

If you don’t have LOOP BACK Adopter, connect X-CTU com port directry other com port using iterlink cable and Run hyper terminal with the port.

X-CTU’s terminal tab is just a terminal.

A lot of thanks for you reponse Nori.
But the problem was that the three RF ZigBee modems was broken!!. It was incredible but I contact with another friend that buy the app kit too and his modems always function correctly.
I contact with my supporter in Spain and change me the three modems, so now I’m programming some applications.
I have one question, if you could help me. How can I run the Rweb_DIO example?? I run it but there’s no STDIO window in Dynamic C.

A lot of thanks and excuse my poor level of english :).

Atte. Pedro Canales.