Zigbee question

I’ve just received the Zigbee starter kit including 3 Maxstream Xbee modules.

I followed the instructions in the documentation and used x-ctu to configure one module as a coordinator(AT).
The module is recognised over the serial port from a PC (running Win XP) and the configuration works first time.
Then I try to use x-ctu again on the same module and get no response at all.

I’ve made a guess that when I’m flashing the module I may also have changed some comms settings so that subsequent attempts always fail, and because of that I’ve tried setting x-ctu to all the various speeds and handshaking.

I used the instructions, didn’t change anything in x-ctu apart from setting PAN ID to 0x3333 to run the mesh networking examples.

I tried again with each xbee module and they have all done the same. The first comms session works, the download is declared a success in the first instance and then it is impossible to communicate with the modules over RS232 again after that.

Is there a hard reset switch on the RF remote board (there are two switches but I’m struggling to find out if they are only application specific and not implemented as resets buttons.

I don’t mind if I have to make a little interface to use Maxstream software to force reset the modules…but then I thought that’s what these RF remote boards were for !

Chris Barron
Nr Edinburgh

…quick update…

I don’t know why but all three modules are now accepting some programming within X-CTU. The programming still fails, however, because the last part of the programming cycle is to set the AT parameters and this fails with a ‘Cannot enter command mode’ message.
None of the modules are detectable from the test function in the ‘Modem configuration’ tab either.

Anyone have any idea what might be going on. ?

It is possible that the baud rate is wrong. I have not been able to reprogram the XBee chips that came with my kit. However, try setting the Baud rate to 11520, and flow control to Hardware, and checking the Enable API checkbox. That at least allowed the modem to be recongnized. If you make any progress please let me know.

I ended up sending both the Rabbit kit with the Xbee modules back.

The kit was labelled as ‘Zigbee’ and the vendor in the UK sold them as Zigbee, but when they came the Xbee modules were series one modules, which are no longer supported for zigbee.

I had to have zigbee compatibility so that was that.

I’m now using ETRX2’s succesfully.

Thanks for the look-in