XBee Series 2: Transmit problem

I have two XBee Series 2 modules. Now i connected one of them via a MAX232 voltage conversion chip to a PC (RS232). I use X-CTU software and can communicate with the module (read and write). Firmware version is 1220.

The other module has a loop-back connection, this means the Data in and Data out pin are connected.
Both modules are connected just by four Pins (Data in, Data out, +3V (stabilized) and GND).

The problem is the radio link between the two modules. I use the X-CTU range test to test this. Change the modules is the same, communication between PC and module works, but no inter-module communication.

Is there something i forgot or should test?



You will need to verify that one of the modules is a coordinator and one is a router device, or else that these modules are currently associated to a particular network.

The default addressing on router devices is to unicast to the coordinator, and the default addressing on the coordinator is to braodcast to all nodes in the network. Broadcast transmissions in a ZigBee network can be very time consuming. The X-CTU software wasn’t initially designed for the extra time that the ZigBee broadcast would take.

You will either need to open up the amount of time before the X-CTU times out, or set the coordinator to unicast to the router, which will speed up the transmission and the software will not timeout.

You can modify the X-CTU under the Advanced button, setting the timeout time from 1000ms to 3-5000ms.

To set a unicast message from the coordinator, set the DH and DL of the coordinator to match the SH and SL parameter of the router deivce.

hope this helps.

Yes, this works. Now i set one module in coordinator and one in router mode and everything is perfect.

My fault was to think, that no configuration is required to use theses modules.

Thank you very much

Hi Michael,

I am starting with XBEE also right now and found the same problems you have.
If you are interested in loos communicaiton on XBEEs, let me know on ms@sse1.de

Viele Gruesse
Michael Schmelz