Programme not going into void applicationStart (void)


I am using Digi ESP for NET+OS 7.0. When I create sample project I can compile the code and run it with the debug icon (the little green bug on the upper right). However when I run it the programme stay in the “void applicationTcpDown (void)” and don’t go in the “void applicationStart (void)”(I saw that by using break points). Nevertheless I can ping the my ConnectCore Wi-9c in my network (but only in ethernet not in Wireless connexion)when the programme is running.

I use a separate network and unsecured.

I am working on this probleme for few days, at the beginning I was using a virtual Com port, and now I use a USB/Serial Adapter to create my projects. I have tried many sample and also a Code wich is working on an other PC but nothing is working on any of my two PC.

Do you have any idea of where the probleme could come from ?


Generally but not always, if you can not get to applictionStart then either (or both) your BSP i snot compatible with your hardware or your debug script (the thing that sets up all of hardware) is not the correct one.

I know that V7.0 had some issues when shipped. Have you gone to the Digi web site and applied all available patches? If not you should.

You might also try setting breakpoints at netosStartup and nccInit (or it might be ncc_init). If you are not getting to netosStartup. If you are not getting to nccInit, then something with memory is probably at issue. Probably your debugger script. If you get to nccInit but not to netosStartup this is still probably a debugger script issue. If you get to netosStartup but not to applictionStart then it could be anything in the bsp that is not happy with something. You’d want to look at things in the bsp.h file in the platforms directory would be a good place to look.


I don’t think my BSP isn’t compatible with my hardware because some people have already run it and it worked.

You talk about patches for ESP 7.0 but I didn’t found any patches on the digi web site and on google too. Where can I find this patches.


All updates for the V7.0 version of NET+OS are available at pid=2601&osvid=127&tp=6&s=0

Or go to the digi web site (
Hit the support link and follow the links to patches

support\patches(embedded only)\pick a product\pick a speed (if appropriate)\choose version V7.0