RCM5600W timout on d/l of Pilot BIOS

I just received my first RCM5600W. Tried to compile (DC10.66) directly to RAM, and it goes through the mating dance, reporting baud rate negotiation, then reports timeout on the device while downloading Pilot BIOS. I have tried a few things, downloaded a new USB driver from FTDI, installed and rebooted. Found a message elsewhere suggesting that I uncheck the option to detect Flash type. Nothing helps.


Select the use usb to serial converter check box from the project options in Dynamic C.
Then it will work.

This seems to be such a common problem. And selecting “USB to Serial converter” is not the solution to all these problems.

I have seen boards that just will not accept flashing when using the USB cable, while they flash properly using the serial cable. Afterwards the USB cable can subsequently be used to flash 100 more boards.

This points to something timing out or a similar type of failure. Is the flashing routine written to fail quickly rather than retry? [=;] I hope not.