Recover erased flash

I tried to update the flash with a kernel image I had but eventually the flash memory has been erased so I wonder how could I recover the entire system to restart again.


ah… Read through the Help contents itself… Recovery preocess is explained there.
BTW are you sure that you have erased the flash??
When you turn on is there any o/p in serial port?

Yes I am pretty sure that I erased it.

In the serial terminal there is nothing, and no input character is recognised. Even it does nothing when I push the reset button.

I think I have to recover it with JTAG as the Help says…

Eitherway thank you Bob you have been so useful. :slight_smile:

he he… Thanks…
Well in some other day maybe your gonna be my help :smiley: :smiley:

Do you have Digi Jlink???
If so this will help you.

No, I have BDI2000 from Abatron.

ehh… you might wanna write to Digi Support asking for the scripts for your JTAG… they will sent it to you i guess.

Hehe hopefully…

I have achieved it. I asked for the scripts to reload the uboot into the RAM, they sent me the JLink files and I had to adapt them to my BDI, but finally it worked!!!