reviving walking dead xbee's ??

xbee type: series I

using x-ctu sw to com test, i get these msg’s returned:

communication with modem…OK
modem type = name unknown (ID = 429496724867206)
modem firmware version =

i’ve tried restoring, i’ve tried usb comm, rs232 comm, xbee dev board, all different bauds, different breakout boards, the line statuses are ok, etc. i do not know if i fried a component of the xbee or what…wouldn’t have thought so as 3.3v reg is in circuit for these and me bench has a huge anti-static pad under projects.

i have a few like this and thought just maybe an engineering guru here had way(s) to revive them versus me tossing them and having to shell out more cash.


In my experience the X-CTU interface can be a little fickled. but, first try using API mode instead of AT mode. If that doesn’t work then try this; exit out of the X-CTU sw: hold down the rest button: cycle power on the X-CTU: release reset: re-launch the X-CTU sw.

Of course, if you had previoulsy enabled sleep mode on the module you may be in trouble. If the sleep mode is ‘pin sleep’ try putting a jumper from the pin sleep input pin (I forget which pin it is) to ground. If its ‘cyclic sleep’ you may be out of luck. I have not been able to recover a module that was previouly put into ‘cyclic sleep’. Maybe someone else knows how to do it?

hey rubout,

thanks for the reply. i got this from’s forum and it revived 2 out of 3 of my xbee’s. two of em were in sleep mode. the third one, well, maybe i fried it. but i’m happy to get 2 out of three and back up running.

these little radios can sure have a mind of their own without letting the dev know what’s a happening. there are some obscure messages from x-ctu. i say obscure to the untrained eye with these particular radios.

i look forward to an updated more powerful x-ctu app especially for editing API packets.

thanks again,


  1. Take the module out of the interface board.

  2. Connect the interface board to the computer.

  3. Open X-CTU

  4. Go to “Modem Configuration”

  5. Put a check in the “Always update firmware” box

  6. Select proper modem from drop down menu,

  7. Select proper function set and firmware version from drop down menus.

  8. Click on the “Write” button. After a few seconds of trying to read the modem, you will get an Info box that says Action Needed. At this point, CAREFULLY insert the module into the interface board.

  9. You may get the info box again a short while after, just use the reset button on the interface board.