S2C and Osram Lightify

Dear Forum,

I am new to this, so please forgive any glaringly obvious misunderstandings on my part.

I am trying to use an XBee S2C on a grove dev board to troubleshoot my Osram Lightify lighting system; its running two gateways (one Pro, one Home) with about 100 devices and 120-130 endpoints.

AFAIK the Home gateway is EU based so used ZLL, but the Pro system I’m not sure about. May be ZLL may be Pro. The Pro

In my ignorance I thought it would be straight forward to put the XBee into system and it ‘would just work’, and Digi email tech support (pre-purchase) confirmed I should be able to connect after configuring with XCTU, but I just can’t seem to get the settings right.

XBee S2C is running Ember EM357 and the Pro gateway has a Silicon Labs Ember EM3587, so loosely both the same family?

My hope is/was to use the S2C as a packet sniffer, using Wireshark, to allow me to observe what my network is doing, and basically try and troubleshoot where I am observing network inconsistencies and failures.

As I’m using OSX, Wireshark can’t monitor a USB port so I am having to drop into Linux; trying this an a Raspberry Pi - but thats another story.

My take is I should be able to get the XBee to at least see and monitor the network, but I’m getting nowhere.

Does anyone have any experience or advice in this area at all?

Any help appreciated.


Have you tried following the steps outlined at http://knowledge.digi.com/articles/Knowledge_Base_Article/Zigbee-Home-Automation/?q=home+automation&l=en_US&fs=Search&pn=1 for home automation?

You will want to set the ZS parameter to 2, and research ZDO commands

Thanks both for the replies.

@mvut - I’ve tried those settings, but the EU Lightify solutions use ZLL not HA, and I suspect the Lightify Pro system uses Zigbee Pro. However, a quick google search revealed the ZLL mastery posted on reddit. Still doesn’t work though.

@DystopianFerret - Yep, got ZS set to 2. As far as ZDO goes, got the AO setting to 3 which should both enable ZDO support and allow unsupported ZDO’s to passthru’. Guessing only relevant in router mode.

However, my (admit limited) understanding is that ZDO’s are only relevant if I can establish a link and join the network. Until then I can’t actually issue any ZDO requests anyway.

Moreover, was kind of hoping just to stick the module in some sort of promiscuous mode in a single channel, passively listening to what network broadcasts are taking place.

But, I guess, step one is the all important issue of getting the network scan and identification to take place.

Currently I’m getting an AI of 23, which I think means PAN found but network join not allowed.

Is there any way for me to ‘observe’ whats going on, other than the AI setting? I mean, can I get some sort of output as to what the module is doing, what channel its trying to scan, what PAN it has identified, and the status of its join attempt, etc?

And have either of you managed to get this working on a third party zigbee setup, such as Hue or Lightify?



As a quick update,

I’ve enabled verbose mode, and I’m getting this as a response.

7E 00 11 98 04 FF B0 D3 BF 0B 00 A8 8C B3 4B 0B 53 AF 72 02 64
7E 00 03 98 0B 23 39
7E 00 02 98 07 60

This suggests that the module is receiving a beacon response (04), but the AI value is changed to 0x23 (0B 23), and that its not an association candidate as the beacon won’t allow joins (07)

Only thing is that the data field of the 04 string does not make sense from what’s listed in the API document.

http://www.digi.com/resources/documentation/digidocs/pdfs/90002002.pdf (page 191)

So, just to update.

the settings I changed to get my XBee to connect to my lightify network were (from default config)

ZS = 2
EE = 1
EO = 1

iirc that was it. No network key needed. Reason?

As best as I can figure, the Lightify Pro gateway (at least) is configured to allow broadcast the network key unencrypted when placed in commissioning mode and a device makes a join request. Thats why the EO is ‘1’ and not ‘2’ or ‘3’.

pretty sure I saw something about that in the ZigBee standard.

once received, key is applied and encryption enabled, but means no PSK needed.

If it doesn’t work, then use the settings as described here


If you want to issue API commands via the console then you will need to set the AP and AO settings, but the above will actually get your device connected to the network.