Setting xbee pro with xctu

I can’t set the xbee module in end device API with xctu.
I selected the flags “enable api” and “using Atap = 2”, and i tried with all baud.
After I tried to select the flag “No baud change”, but the result is the same.
Finally, I raised all selections, and i tried with all baud, but xctu always loses communication.
The error when i read is:
“Failed to enter command mode
Unable to read Version (ATVR)
Read parameters…Failed.”
The error when i write is:
“Getting modem type…OK
Programming modem…Lost communication with modem
Write Parameters…Failed”
When i click in “Test/Query” button, i get this message:
"Communication with modem…OK
Modem type = Name unknown (ID = 42949672481981785178)
Modem firmware version = "

You can help me?
Thanks in advance

I know this is quite an old post, but I hope this helps.
Under the “modem configuration” tab, in the “serial interfacing”, make sure the API Enable is set to 1.
This should correct your problem.

I am using just the basic version of the XBee, not XBee pro. But I guess it should be the same.