Sharing Violation


I bought the Digi XBee-Pro ZB Development Kit and am having trouble reading two XBee Pro S2B modems that came with the kit. When I try to read the modems in the modem configuration tab of x ctu, this error message displays:

“A sharing violation occured while accessing C:\program files\digi international\xctu\update\xcite\010C_02.mxi.”

I have no problem reading a series 1 XBee using the same development board I used with the XBee Pro S2B modems (XBIB-U-DEV REV.3).

The XBee Pro S2B’s have always been a bit finicky to get to read and write properly but this is the first time I have seen this message.

Can anyone help me?




I just ran into the same problem with an XBee Pro S2B. Which version of Windows are you using?


Hey David,

I’m using Windows 7.


Me too. I think that may have something to do with it.

I will look into the problem tomorrow.

Thanks David. I tried troubleshooting the best I could before posting to this forum. Good luck.

I have a few more questions:

Is this the development kit you have?

What firmware do you write before you get the error when reading?

Are you using the rs232 or usb board?

Do you know how to interact directly with the ember bootloader?

Hey David,

I’m using the xbee pro zb development kit:

I am using the usb board.

No, I do not know how to interact with the bootloader, and I think with these XBees (XBP24BZ7) its a freescale bootloader.

I am actually having different problems with both of the Xbees. I will describe my issues with them below:

First Xbee:
I first try clicking the test/query button under the pc settings tab and get this message, after a good 20 second wait:

Communication with modem…Ok
Modem type = Name unknown (ID = 96309)
Modem firmware version = }WW[ί

Serial Number = }W[oί}W[oί

Then, I go to the Modem Configuration tab and click read and the Action Required box shows up:

Action Required
Unable to communicate with modem.
Verify com port selection then perform the action below or Cancel.

I try resetting my board and nothing happens. That is as far as I get with that Xbee.

I have also tried selecting my specific XBee’s firmware (XBP24BZ7) and then writing that to the Xbee and end up getting the same Required Action box that won’t go away.

Second Xbee:

I try the test query and it says :
Communication with modem…Ok
Modem type = Name unknown (ID = 4294976294309)
Modem firmware version = ~

I then go to Modem configuration and click Read. The Action Required box pops up quickly and then dissapears. Then, the sharing violation box pops up.

Actually, when I tried the test/query another time the firmware version and serial number showed some really messed up characters.

Are you certain that you have the baud rate set properly?

> No, I do not know how to interact with the bootloader, and I think with these XBees (XBP24BZ7) its a freescale bootloader.

We can find out. Here’s how to write a new image using X-CTU.

  1. On the “PC Settings” tab, set the following:
    Baud = 115200
    Flow Control = None
    Data Bits = 8
    Parity = None
    Stop Bits = 1

  2. On the “modem configuration” tab, select an appropriate modem and function set. (For testing your device, I would select “XBP24-ZB” and the “ZigBee Coordinator API” function set.)

  3. Change to the “Terminal” tab. Uncheck “RST” and check “Break” in the “Assert” area. (“DTR” should already be checked.)

  4. Press reset on your device.

  5. Uncheck “Break”.

  6. Click on the main window area in the “Terminal” tab (the big white space), and then hit the enter key.

The device should print out something like this:

.EM250 Bootloader. v20 b09
.1. upload ebl
.2. run
.3. ebl info
.BL > .

(If it doesn’t, please tell me what it says.)

  1. Press 1. It should say “.begin upload”, then start printing out lots of "C"s.

  2. go back to the “Modem Configuration” tab and click “Write”.

  3. The firmware should write successfully. Since the default baud rate for most firmware images is 9600, change your baud rate to 9600.

  4. Go back to the “Modem Configuration” tab and hit “Read”. It should work now.

Hey David,

Are you certain that you have the baud rate set properly?

I’m pretty sure my baud rate is set at 9600. I didn’t change it before I ran into these problems. I also clicked the test/query button for each baud rate and ended up with the same weird response of a bunch of weird characters.

I tried your steps for writing a new image and instead of getting the message “EM 250 bootloader…” all I got was a period when I clicked enter on the screen.

Please walk through the steps again and tell me what the 3 status lights on the development board are doing at each step.


You can configure the baud rate (and the default is 9600) for communication with the firmware after the board boots. This is the normal way you talk with the device in X-CTU.

But the boot loader always (to my knowledge) uses 115200. To get to the boot loader menu, you must follow the steps at a baud rate of 115200.

I hope this helps.

(and sorry for the late response… I missed your last comment)

Ditto here.

I have a XBee ZB SMT development kit and am experiencing the same sharing violation: A sharing vioaltion occurred while accessing C:\PROGRAM FILES\DIGI\XCTU\update\scite\010C_02.mxi.

When speaking with Allison in tech support yesterday, she was unfamiliar with the error and has run up to 10 instances of the CTU. The sharing violation occurs after a second instance is started, but will then reoccur even if only one instance is executed.

Test/Query will still work, but the Modem Configuration functions are disabled.

Using a utility called Unlocker, I see that two X-CTU.exe’s each have handles on the 010C_02.mxi file. However, only one instance of X-CTU is running. When I close X-CTU, both of the handles are released.

At this point, the bugs with X-CTU are hampering any meaningful progress. I am also seeing “Unable to open com port” errors. At times, CTU will also fail to close a com port. The other radio modules that I have been exploring over the last two weeks are starting to look attractive.


Here is a work-around from Brenton at Digi tech support.

Delete the XCITE directory from C:\Program Files\Digi\Xctu\update\

Download the XBee/ZBee-PRO ZB SMT OEM module firmware from the Digi Support >> Firmware page. Save the files to your PC.

From X-CTU, use the Download new versions… button and select File and navigate to the location of the downloaded zip file. DO NOT use the web or you will have to restart this process. The web download also does not contain the S2C (ZB SMT OEM module) firmware.

In the Modem Configuration tab. Select the Modem drop down list and ensure that the XB24C and XBP24C modems are listed.

Good luck.

Please submit any corrections or clarifications to the above procedure.

There are a few other bugs that I am struggling with, but at least I can now work with the modules.


Hey Eugene,

Thanks for sharing the information, I will try it out as soon as I can and let you know how I do.


Hey Eugene,

I followed your steps applicable to my modem (XBee ZB S2B). Unfortunately I am still having problems trying to read my modem but at least I no longer receive the sharing violation message. So is this xcite folder used for grabbing firware updates from the web? And by downloading the firmware locally we can bypass xcite? I have a couple other modems that aren’t screwed up and I want to make sure that doing this won’t affect them in anyway.



The XCite is a different Digi radio product. Unless you are working with this particular version, deleting the directory shouldn’t cause a problem.



I am having the same problem as well.

I am on Win 7.

Also, don’t know how, but this morning I managed to made it working and then it stopped working right after :S

Any help please…

Can you try running XCTU As Administrator? Also make sure you’ve exited XCTU at least once, and perhaps reboot. Since XCTU is storing images into the Program Files directory, it can suffer permission problems.

Actually, a interesting twist to this. My Win7 just started doing this. Worse (or more weirdly) XCTU creates a XCTU\update\scite\ dated 2006! Delete it, and it returns the next time this error shows up.

This only happens when I hit the READ button and XCTU does not have the firmware files of the target XBee. Instead of popping up that ‘do you want to check the web site’ pop-up, I get this sharing violation (perhaps because the file is open by ZIP?!?!).

My simple work-around was just don’t READ the xbee, select the type and reflash the critter to the desired level. This works, then XCTU and life are fine until I hit another old XBee with weird BETA firmware long since lost from my system. :slight_smile:

Hi, I have been the same problem, but I have the solution!

Steps for the solution:

1.-9600, N, 8, N, 1
2.-Enable API = 0; No Baud change = 0
3.-Selection the Modem (XBP24B27); Zigbee cordinator API
4.-I can’t remember fine this step (I can’t make now), but…
I uncheck RTS
I check BREAK
and show me this menu:

A to enter Bootloader
B to enter Bootloader ByPass mode
(RESET will Reset Freescale)
C to enter Custom ByPass Mode
(RESET Button Resets EMBER)
(Power Off to reset Freescale)
F for an OTA Flash Update
I to cause an Illegal Instruction Reset
R to force a Watchdog Reset
S to sleep module
V to Read APP Reserved Flash
W to Write APP Reserved Flash
E to Erase APP Reserved Flash
Q to Quit this menu

5.-Type C

App Version: APP32_Transparent_09.4
BLResetCause = 0001
Watchdog Timeout Reset

ByPass Mode Started.
Use RESET Button/Line to reset EMBER radio.
Turn power off and on to reset Freescale

(Programming module!)
7.-OK. Now I can read a lot of parameters! It’s possible read fine and Test/query Ok.

“A mí me funcionó así. Espero que sea de utilidad para ustedes”
For me it’s ok. I would like this steps be ok for you.

Good luck!