Static IP address problem with netosprog


We’ve received a batch of modules which have been configured to use a static IP ( by default. Now, we would like to reset them to get the IP from DHCP.

We’ve been advised to use NET+OS Programmer ( with command:
netosprog /set /mac=auto /ip=dhcp

It does manage to find the module and reboot it, but then results in error “Failed to change DHCP mode”. This happens wheter the computer is set to the same network, e.g. or DHCP mode.

If we use command
netosprog /set /mac=auto /ip=
it says the IP address has been changed, but if you then use netosprog /discover it shows that the same static IP remains.

We’ve also been told to clean up the ARP table after every such command but it ain’t helping.

Anybody ever experienced such problems? What should we do next? The modules are of no use if the IP is not changeable.

Appreciate your help. Thanks in advance.

Message was edited by: d_monitor

My recommendation…

Call Digi support and tell them that there cute little programmer is B.D. (that’s broke d#$%).

Then exchange your B.D. modules for ones that were programmed properly.

Just one person’s opinion…

I’ve already had this problem with their ConnectME modules. Their Quality control department is really interested in finding out why these are getting by them. Please talk with Cameron so he can schedule their QC department to get some of your modules.

Anyway, here is what you can do if you haven’t loaded a new image.bin into them:

Connect a serial cable from the Digi to your computer. Set your computer up to 9600 baud. You will get their default dialog menu. From there, you can change their DHCP setting.

I would also check their MAC addresses. Make sure they are correct (compared to the sticker). If they’re not, you need to get an RMA and have Digi repair them. Don’t waste your time with them.


Thanks for helping out. However, these modules are the C series, so no serial communication is possible. Suppose there’s nothing we can do, so the modules are on their way back.

Thanks anyway.

I also have problems with DHCP. Works file with a static IP. Used the function customizeGetIPParameters(); to get current network parameters, works fine with static IP but does not work with DHCP set (yeah figures)
For DHCP, do the gateway and Subnet fields need to be set or are they just ignored when DHCP is selected?
I ended up stealing an IP off of the LAN. (them IT guys may hunt me down, but I will hide from them :slight_smile: )
I did find a way to get the IP address woth the program Ethereal.
Tried another ConnectME fresh out of the box (FTP app runing in it) that came with DHCP already set, tried it, it did start up(as seen from serial port), but the discovery tools can’t find it. I then Used Ethereal and logged a short amount activity when the connect me is coming up, trying to get an IP from DHCP.
Saw the DHCP requests and soon after that I saw the MAC address for the digi and the IP that was given to it. I then used ftp, and saw: 220 NET+ARM FTP Server 1.0 ready.
So I found it the hard way.