Trouble setting up a DigiMesh transparent mode! Urgent!

I have a two XBee S1 2,4 GHz (XB24-AWI-001 revH) -
I was updated firmware from «802.15.4» (10ef) to «XB24-DM» (DigiMesh 2.4 standart 8073).

Following the instructions in the manual ( ) I have error in middle of step 3 “check the network”. My modules can`t find each other. I checked all that it possible.

I need a mesh network on protocol Digimesh for data transmission from one PC to other through a large area.

Please, help me! How I can do mesh network now on this module? Or am I forced to buy other modules?
The deadline is soon…((

Try starting off by Doing entering command mode and resorting to defaults. Do that on both units. Then they will communicate.


If you skip the “Check the network” section, does the “Send messages through XCTU” section work?

No. And default settings also don`t help.

It didnt help. Im trying yesterday resorting to defaults pushing the button “Default” and then “Write”. Modules didn`t communicate :-(.

In general XB24-AWI-001 support Digimesh? Im afraid that it unpossible, but dont know the truth.

What are the DL and DH set to on all of the nodes? Make sure they are set to the broadcast address of DH 0x00 and DL 0f 0xFFFF.

Unless the module was one of the very first ones produced, it will support Digi mesh 2.4 with firmware versions 8003 and older.

How far apart are the radios from each other? Are the wire antennas straight up?

No, I set the value of DH and DL as SH and SL of the receiver module. From receiver DH and DL as the sender. This was said in the starter guide.
Today, the system worked in this mode, but when you remove the receiver out of reach area and return it back the connection is no longer established. Now again, the modules do not see each other at all. I think that reflashing will solve the problem, but each time to do so? It’s uncomfortable.

First, the modules were at a distance of 20 cm (7.87 in), the system worked successfully and the data is passed. Then I left the transmitter on the cyclical transmission of the message, and the receiver was removed at 30-40 meters inside the building (a few rooms). There, the signal was not received. When returned the system to its original state modules no longer see each other.
On the sender antenna was vertically on the receiver PCB antenna.

P.S. This post-translated program. No time to write it himself.

Are you using sleep modes?

What firmware version is installed on each of the modules in question?

It was 8073 DigiMesh 2.4. Now I`m testing 8003 version.

No, I`m not using sleep modes. But I want do it in the future, if all will be good working.

Try setting the NI value on both to a unique value. Then try using the ATDN command with the NI value of the other module. What this will do is force a new rout discovery to occur.

30 meters is the limit for indoor communication, and that range will decrease depending on other environmental factors like physical obstacles and other 2.4 GHz radio sources.

So is the problem that you don’t have the 40 meter range? Or is the problem that they don’t find each other when they are brought back together?

Now they finded each other, because I`m install 8003 firmware (very old) and set default settings.
PCB antenna broadcasts in the area solid angle of 45 degrees upward of the chip. I just installed it empirically. Bad antenna.
Now I will be testing the AWI version (with wire antenna).

I know about the limit of 40 meters.Thank you.

Will report on the results

Yesterday morning I could send data with help 8073 or 8003 DigiMesh firmware. Everything worked well. I cut the power and after lunch turned on again. And now it are not find each other in the air! Why? I use a laboratory power supply.
Before it I disconnect module from one laboratory power supply, connect from other laboratory power supply and it`s worked - send data. All was well.

Now modules connect with PC. I can update firmware, but none of the firmware does not help.

Thank you for help.