unable to communicate with modules

hi everybody,

I think I have this modules XBee-PRO® ZB, the reference is XBEEPRO2. (I don’t buy it, i’m not sure. I recovered this modules on an other project…it’s complicated to explain)
I hesitate with this reference too : XBee-PRO® ZNet 2.5

But I believe that the difference between both is the firmware ?
firmware on XBEEPRO2 isn’t compatible with XBee-PRO® ZNet 2.5, but you can installed on XBEEPRO2 a firmware “XBee-PRO® ZNet 2.5”
Am i right or not?

But the biggest problem is not here :
I have 4 modules and a RS232 board (like you can see here : rs232 board ).

I supply my board with 5V DC (so one wire is soldered to “+” of Vin and a other for GND. on the picture, it’sin the right top corner), it’s OK ?

And when I plug my board to my computer (with a cross-wired RS232, I’m sure of that. It’s not a straight wire) XCTU is unable to communicate with my modules (see picture for settings:pc and xctu settings )

the settings are right ?

I have an error mesage which say unable to communicate (see picture error message ).
So I tried to reset my modules. With a wire : one side on “GND” and the other on PIN 5 during 2-3 seconds. but no change !

my 4 modules don’t work, it’s the same message for all. I tried to change baud, check “enable api” but nothing changed.
One day one module worked but the day after the module was’nt detected, I don’t understand !
But now with one module the led ASSOC blinks, with the others the led is OFF. what does it mean?

I really need your help

so what is the problem ?

thanks for your help and sorry for my english
and if you don’t understand anything, please let you know I will try to be more clear

have a nice day
molin

Hi,

Yes, you can upgrade from ZNet 2.5 to ZigBee, refer the following link, http://www.digi.com/support/kbase/kbaseresultdetl.jsp?id=3025

If you are unable to communicate with the modules, re-program the modules with proper Modem, Function set and version using X-CTU.

PC Settings in X-CTU are correct.

Still if you are facing same issue, refer the following video which specifies “How to recover from a failed firmware upgrade”, http://www.youtube.com/watch?v=fxOqQZD-oaM

Hope this helps!

hi,

thanks for your help !

Unfortunately, I have already seen this video (I wrote to the Digi support). When I have the error message I press the reset switch but this action hasn’t effect…normally this action should close the dialog box but here no. The dialog box is still open !

so what is the problem ? My xbee modules aren’t damaged?

thanks again

Hey have you tried the procedure for failed xbee firmware video hosted on you tube link properly. Don’t worry about test/query.