USB Anywhere event error usbkey ID 517

I have a usbanywhere, and a VMWare ESXI server, no problem to connect a drive usb on my server, but with my dongle key (KeyLok) i have an error system usbkey ID 517


Thanks for your answer


Please upload the following screen captures:

  1. The error you mentioned.

  2. AnywhereUSB Configuration Utility (main window).

  3. AnywhereUSB Configuration Utility (click “View / Driver Information”).

  4. AnywhereUSB Viewer Utility (maximized) with the dongle highlighted on the left-hand side.

  5. Windows Device Manager (maximized) with the “Universal Serial Bus controllers” section expanded.


I’m not sure what that error message means, especially because it’s in French. Would you please try to translate it to English for me?

Also, besides what you’re seeing in the Event Viewer, what is the actual issue? I presume that you’re having some kind of “real” problem with the dongle, which led you to look in the Event Viewer.

I install in US OS, same error

Thank you.

Besides that error, what exactly is the “real” issue that led you to look in the Event Log?

For example, presuming that there is some software associated with that USB license dongle (software that “looks” for that dongle, in order to run), how does that software behave? Is that software, perhaps, generating an error message?

When i install in local computer (no VMWare) on local machine, it’s OK, when i used on local machine USBAnywhere i have same error !!!

I watch this post :
USB device transfer type shows interrupt instead of Control?

it’s the answer from my error,

Thanks for your help

Is the issue resolved now? Did some information in the other post help?

It’s OK now.
This was a project using the KEYLOK security dongle.
1- Uninstall the device from Device Manager.
2- Run the driver installers UNINSTALL program and remove the old drivers,
3- Disconnect USB Key.
4- Reboot
5-Install the drivers
6- Plug the USB Key into the anywhereusb5
7-Restart the app
Now It’s OK in VM