USB device transfer type shows interrupt instead of Control?

I am looking to virtualize a server that has a security dongle. The only difference I see between when it runs directly on the physical host vs the AnywhereUSB device is that under Transfer Type is says Interrupt instead of Control.

Any ideas?

I also see Event ID 517 usbkey which is an very nonspecific message

The only kind of Transfer Type that the AnywhereUSB does not support is “isochronous”. Bulk and Interrupt are fine, so I wouldn’t be concerned with that.

Tell me, what exactly is the issue that you’re running into? I presume there’s some kind of symptom that led you to look in the Event Log and the AnywhereUSB Viewer Utility.

Yes, the main problem is the app is not seeing the device, even though it appears a-OK in device manager.

When I fire up the service, it fails, and when I check the applications log files, it says it cannot see it. Digging further, I looked in the event viewer and saw the following error:

The description for Event ID ( 517 ) in Source ( usbkey ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: \Device\KeyDongle_0.

The problem seems to be that it shows up as “Control” when I plug it directly into the server, but “Interrupt” when I plug it into the anywhereusb5.

Personally, I’d call it more of an observation than a problem that the dongle is showing up as “Control” vs. “Interrupt”. That’s a good observation and it COULD be the source of the issue, but from my experience it isn’t. Please upload screen captures showing this behavior.

FYI, we have had reports of this kind of behavior before, where an app related to a dongle can’t find the dongle, although the dongle seems to be installed properly. Have you also looked in the AWUSB viewer util? Is the dongle “OK” there as well (no yellow warning icons)?

What AWUSB driver version are you running? To determine this, click View / Driver Information and note the version of the first file awusbsys.sys (or possibly awusbsys64.sys). Have you tried other AWUSB driver versions? If so, which ones?

What is the driver version for the dongle? Have you tried other driver versions?

A couple of end-users reports that the following suggestions resolved their related issues, so try them out and let me know the result:

  1. Go into the BIOS of the PC and disable the parallel port, if it’s not actually being used, of course. Note that virtual machines have BIOS’s and even if the physical PC that the virtual machine is running within doesn’t have a physical parallel port, the option still may be in the BIOS.

  2. Disable DEP (Data Execution Prevention). This is applicable to Windows Server 2003 for sure. I’m not sure about other OS’s.

I will have to wait till Monday evening to get the screen shots, this is a production box that I can’t touch during the day.

I am running the following:
Windows 2003 Server R2 SP2
AWUSB driver version:2.70.14 and have tried 2.4x (the one on the CD)

I need to find out about other driver versions for the dongle.

I tried doing all of the below (DEP/Parallel Port). The machine hasn’t changed, I am testing this on the physical box before attempting to migrate to an ESX host. Right now the idea is to get it working on the server that has hosted the software for a year or so and if I can get it to work here, I can likely get it to work in a VM.

I got it working!

This was a project using the KEYLOK security dongle. Bascially, I had to uninstall the device from Device Manager, run the driver installers UNINSTALL program and remove the old drivers, pull the USB Key, reboot, install the drivers then plug the USB Key into the anywhereusb5 and restart the app. Works like a champ. Now I can VM this box!