Web access broken after upgrade - portserver TS 16

I went and upgraded my firmware (both POST and FEP) following the procedures on listed on the firmware page for the Portserver TS16. The web access is now broken. Specifically, when I try and click on any of the links on the left (Configuration, Setup Wizard, Admin, etc.), it just keeps taking me to the main page.

The CLI (telnet) interface appears to work just fine.
Here’s the only information which appears on any of the web pages:

Model: PortServer
Type: TS 16
Firmware version: Version 82000854_J1 06/15/2004

I tried to upgrade to a later release, but I got an error message saying the image wouldn’t fit.

Any ideas on what I can do here? I’d really like to get the web interface going, as I have another one of your products, and that interface is REALLY well done!

Thanks in advance

The firmware which can be used for the TS16 is dependant on hardware revision, which is why we have a number of part numbers listed on the firmware page for that model:


Which part number is found on the underside of your TS16’s chassis?

Thanks for the fast response!

It’s (1P)50001207-01 c

You will want to use the 82000854_J1.bin image from the following link:


This firmware image supports the PortServer TS 16 - part number 50001207 Revision E and lower

Thanks, but wasn’t I using that already? As per the version string in my original message"

Anyway, I tried reflashing with 82000854_J1.bin again, and still get the same version string when it comes up:

Model: PortServer
Type: TS 16
Firmware version: Version 82000854_J1 06/15/2004

Here’s some more info. Most of the links point to main_info.htm, except for logout. That takes me to the logout page. But when I logout, I can still get back in without having to type in a password. That seems like some sort of mishandling of cookies.

What web browser are you using? Have you tried another browser or clearing the cache?

Firefox. I tried clearing the cache at one point, with the same results.

FWIW, I have another unit which works just fine. Here’s the revision info:

Model: PortServer TS 16
Firmware Version: Version 82000684_J 04/29/2004

I’ll try it with some non-IE browswers.

I tried it with Konqueror, and it worked just fine!

It definitely wasn’t a cache or cookie issue, as I set the IP address to something different, and still saw the problem.

There must be some odd incompatibility between that version of the FEP software and this version of Firefox. Something with works with the 82000684_J version, and with the version from 2001. Odd.

Anyway, thanks for the help and the suggestions! The portserver is a superb piece of equipment.