Where is rom.bin?

I’m using 7.4.2 for ConnectME. When I build my app, or any sample app, I don’t see rom.bin being created anywhere on my PC. On 7.3 and back, I always got a rom.bin and image.bin, which I then merged to create a full application. Is this somehow done for me now?

In Project–>Properties–>C/C++ Build, Change ‘Configuration’ to ‘Release’
This will create a separate ‘Release’ directory in your project, with rom.bin and image.bin

Thank you, I had just found that when I saw your reply.


I have the same problem. I’m using NET+OS 7.4.2 for connectcore9p9360_a. After I build or rebuild a app. project, I just only get image.bin, no rom.bin. Even I changed in Project–>Properties–>C/C++ Build —> ‘Configuration’ to ‘Release’ and rebuild it.

Could you help?

Best Regards

Maybe you need to select “NET+OS Rebuild” instead of “Rebuild Project”.

Hi daworm,

many thanks for your response.

I have selected the “NET+OS Rebuild”, but there ist still no rom.bin.

I have now the suspicion, that a parameter should be set for generating the rom.bin file.


A project ‘clean’ and rebuild in release mode will certainly generate rom.bin.
(The makefile seems a bit reluctant to decide that rom.bin needs to be built - it doesn’t even notice its not there!)

BTW, I just checked. On my system anyway, the rom.bin (and an image.bin) was(are) placed in the release folder, as opposed to be placed in the binary folder. So ensure that you are looking in the correct place (correct folder) for the rom.bin

1 Like

Hi all,

which system are you using? I’m using NET+OS 7.4.2 for connectcore9p9360_a and still didn’t get the rom.bin file.

I took a total new directory and generate a new project through File –> New –> NET + OS Project …, thus it should be clean, and then “NET + OS Rebuild” or “Rebuild Project”. Both are tried, but no way to get rom.bin file. I’m really confused.

steved2, are you sure, we don’t need to change any parameter to generate the rom.bin?

I searched the whole directory, no rom.bin file is there.


Anyway I think the parameter BUILD_ROM_IMAGE should be changed for 7.4.2 from 0 to 1. I did this, but the rom.bin file is still not there. Thus it seems not enough.

There is no rom.bin for the ConnectCore 9P 9360. It uses Uboot.

Try connecting to Serial Port A at 38400,8,n,1,n and power on the device. If you get UBoot then you just need to upload image.bin.

Hi mcarver,

I got your point, there is no rom.bin file for the ConnectCore 9P 9360. It uses Uboot, thus there is a u-boot.bin file.

From my point of view, the functionality of rom.bin or u-boot.bin ist nearly the same, namely initialising the system at the beginning and starting some simple application. I’m right?

Thus, if we want to change some settings in the initialising process because of any reason, we have to re-build u-boot.bin file. My question is now, how can I re-build the u-boot.bin file? Or for the ConnectCore 9P 9360 we may not change the u-boot.bin, may only take the default?

I connected the Serial Port A at 38400,8,1 to PC and power on the device. The UBoot comes up, that’s ok.

could someone answer my above questions to give me some advice?

Many thanks