X-CTU can't use the modem configuration gui

I’m having problems using x-ctu to configure xbee-09P modules.
If I click on the read button under the “modem configuration” tab I get a window pop up “The modem configuration file was not found. Would you like to check the web site for updates?” If I click yes it seems to download new updates. However If I click read again, the same thing happens. It seems to be complaining about a missing .pro file, and NONE are ever downloaded. I’ve also tried using the “download new versions” button. If I set the modem type from the drop down window (XBP09-DP ?) and press the read button the same thing happens. If I press the ‘no’ button on the pop up window, the displayed status is read-ok.

The terminal mode does work, I can manually issue AT commands and I’ve got communication between two modules. I can read the SH and SL and set DH and DL (had to use the assemble packet button in order to type in the command fast enough to avoid timing out the AT mode).

So what am I doing wrong, why can’t I use the configure gui?

BTW, I’m running on Windows-7 ultimate (32 bit)


This may happen if you have old firmware loaded on the xbee and there is no equivalent .mxi firmware file on you local PC.

Go to PC setting tab and do test/query. You will get xbee firmware version. Now contact to Digi Technical Support through Support Web Portal and ask for the .mxi file for the perticular firmware version.

Once you get the appropriate firmware version from them then load to the local PC from Modem Configuration – Update – from file.

Your problem would be solved after that.