XBee Problem


I inserted an XBee (1mW chip antenna) into an XBee breakout board and connected it to a laptop via an FT232RL board. Using X-CTU the XBee could not be detected. I have tried various things, but without any success. I have detailed below the steps I have taken, and the responses I got.

  1. The module is in AT command mode, I get “unable to communicate with modem”. This happens for all baud rates including 9600.

  2. When the API box is checked and Test/Query button in X-CTU is pressed, the following message comes up:

Communication with modem OK…
Modem type: Name unknown (ID=42949672481977066586)
Modem firmware version:

  1. Following on from step (2) with API box still checked, I clicked on the Modem Configuration Tab and the READ button is pressed, the following message appears:

Failed to enter command mode
Unable to read Version (ATVR)
Read parameters failed

Although the “read parameters failed”, when “+++” is entered into the Terminal tab field I get gibberish: FF FF FF FF etc.

Has anyone come across this before and been able to solve it?

Please note: I verified that the problem does not lie with the XBee module. By inserting the XBee into an XBee Explorer USB, the XBee was detected successfully and I was able to communicate with it (using X-CTU).



Have you gone through the FAQs? Many ways are described over there. You will find FAQs in XBee 802.15.4 category.


I tried out loads of suggestions, but nothing works for me. One suggestion made was to attach LEDs to the XBee module. So I attached LEDs to Pins 6, 13 and 15 on the XBee module, as was suggested. Pin 6 is RX strength indicator. Pin 13 is the module status indicator, and 15 is the Associated Indicator.

LED on Pin 13 turns on when the Xbee is powered on, and flashes when I click on Test/Query. So that works as expected. However, the LED attached to pin 15 does not come on at all and neither does that connected to pin 6.

I’m thinking it could it be my soldering. Any thoughts?


One thing is while connecting to the PC proper cable need to be used. So check out have you used proper cable or not? If you are using using, Serial cable, then Check it out, whether it is straight or cross cable.

try to reset the xbee (with Switch RST or put pin 5 to GND for 10 secons or more) check the FAQs