AnywhereUSB only recognizes devices on OS restart

When I plug any USB device into my AnywhereUSB2, Device Manager says ‘Unknown USB Device (Device Failed Enumeration)’. Restarting the VM makes it show up properly. Is there a way to make inserting a USB device in AnywhereUSB behave as it would on a local machine?

AnywhereUSB2, Windows Server 2102 R2 on VMWare.

You will want to start by confirming you are running the most current AnywhereUSB firmware and driver, as well as, the latest driver for your USB device.

If this does not work, you might want to take a look at the knowledge base for possible solutions/troubleshooting steps:

Thanks for your response. I was running the most current driver, but I have found a document online that says that in order to use AnywhereUSB with a VM I need a file called usbd.sy_ from the original operating CD. This product did not come with a CD, and I haven’t been able to find that file on Digi’s ftp site. Any idea where I can find that file?

You only need to get that file if you are getting a error code 39 in device manager.

You would need to obtain the operating system cd to extract that file if you are getting that error. Another method is to copy that file from a existing computer if needed.

Well I’m kind of stuck here. Nothing in the knowledgebase describes my problem. I added the usbd.sys file just to see if would change anything, no difference. I tried to open a ticket but apparently I would need to pay for support first - for a product that doesn’t work right out of the box.
I will keep trying, I really hope to be able to use this device.


To answer your question, attached USB devices should behave the same as if they were attached locally without any special configuration. What you’re seeing is abnormal.

What kinds of USB devices are you using, and do you see this problem on a different computer (physical or virtual), or is the problem particular to this VM?

Thanks for the replies. With the AnywhereUSB connected to a virtual machine I tried connecting various flash drives and a USB mouse, with results as described in my original post.
I tried connecting to a physical machine on the network with a new set of issues. On the physical machine (Windows 7, 64), the configuration utility sees the AnywhereUSB and says, “connecting to this host pc” with a driver status of “can not find remote hub at”. Lights on the USB ports of the device are dark, and a restart of the OS and reboot fo the Digi device don’t result in a successful connection.
Over the next few days I’ll throw more testing at it, I’m still optimistic this will be usable on our network.