I’ve got this problem (see the picture), have I bricked my XBee?

What I did was I load the AppTransparent code into the XBee and it stopped working since.

The first time I connect the device and press the test/Query button, it worked fine.

Also, the Baud is 9600, Flow Control = NONE, Data Bits = 8, Parity = NONE, Stop Bits = 1.

I’ve have 2 of these XBee Pro S2B and both of them have the same problem…

Any help… please


Which varient of Xbee S2B module, do you have?
-Programmable or Non-Programmable.

From the figure that you have shared, it seems like that you have XBee S2B programmable varient.

In this case, you need to go to the Terminal window and Write ‘B’ and press enter. One manu will come, from where you will need to bypass the freescale processor inside it by giving appropriate choice and then do ‘Test/Query’.



Thanks so much, you have just fixed the problem that I’ve been trying to work out why for the pass few days. And you have just saved be degree :D:D:D

Yes, it is a programmable device.

So, is it the freescale MCU played me round for the pass few days?

Hello, greetings from Brazil!!!
I tried what was explained but
look what happened(see picture below),

as also I have 2 xbees bricked like this…

any help would be great full!

Mine was bricked and was told by the digi guys to reset the e250 through software… but not too familiar with coding, so I used a wire to reset the e250 manually, using the TP6 pin to ground. Check page 18 of manual for the diagram.

Since I don’t know the exact combination to get the module to unbrick, try everything:

  1. Bypass mode
  2. change baud rates 9600-115200
  3. read and if that doesn’t work, write with default
  4. when asked to reset, try reseting with the method above, or regular reset on the board

if all of this doesn’t work, light it up in flames.