Connecting Epson TM-U210D with Edgeport 1


Please excuse my poor english, as i am not a native english speaker :slight_smile:

I am trying to connect a ticket printer (Epson TM-U210D) on my laptop computer (Toshiba Satellite - Vista) with no success … keep on saying “unable to write on port number 9”

I tried on my 2nd computer (XP SP2) but same message.

What can i do ?

Many thank in advance.



Shut down the laptop and disconnect the printer from the Edgeport. Power on the laptop and open the Edgeport Configuration Utility from the start menu (it should be in the “Inside Out Networks” or “Digi USB” program group). Click the “Test Ports” button and then click “Begin Test”. Does the port pass or fail? What COM port number is the Edgeport assigned to?


Test pass succefully.

I tried to look at the port status … the port is open … but only the RTS and DTR flag are on, i have a Tx Total = 26, all other value are 0.

If i try to print without printer connected i get exactly the same message and the same result in the log.

Please help :slight_smile:



The Edgeport appears to be in working order.

I suggest contacting Epson technical support, as they are more familiar with troubleshooting their printers.


Will try that way and post here the answer if i got one :slight_smile:



Everything is working fine now …

Originally, the printer was connected to the PC serial port by a 25pin serial cable printer side and a DB25<->DB9 convertor PC side.

At the beginning i connected the printer using directly the DB9<->DB25 convertor on the edgeport 1 adaptator.

This morning, as i wanted to try on a third PC, i used the DB25 cable to reach this new PC … and miracle … everything was going fine.

Tried with this configuration on first PC on Vista … wow … no problem at all, printer is printing :slight_smile:

Must be a cross-cable or something like this.