dccl_cmp.exe not showing any output / errors or warnings

We’d like to automate build process for binary images for RCM22xx, using Dynamic C 9.62.

I can compile with ‘dccl_cmp.exe -br’ setting my main .C file, and obtain binary image from windows shell.

Problem is that no output is shown to console (warnings, or even error if ocurred).

I’ve gone through options explained in ‘dccl_cmp.exe -?’, (e.g. telling the max number of errors or warnings with -nw or -ne, or sending output to a file with -o). But none gives result: output file is always empty.

Though, if I do compile inside DCRABBIT 9.62 environment, I do see warning/error messages in a separate window, after compilation.

Is there any option to enable output from command line compiler?


Hmmm. I think I’ve just confirmed what you’re seeing.

I added a single line “#warnt This is a warning.” to one of the samples. When I compile it in the GUI, I see the warning. When I compile it from the DC 9.62 command-line compiler, I do not. When I compile it in the DC 10.72 command-line compiler, I do see the warning.

Using the following command-line:

dccl_cmp Samples\PONG.C -br -wa -h

I see the warnings when I use DC 10.56 as well.

I went back to Dynamic C 9.52, and it displays the warnings as well. It looks like there were some bug fixes to the compiler between those two releases, though, so I would not recommend using the command-line compiler from 9.52 with the libraries/samples from 9.62.

I’ll investigate further to see if there’s a possible workaround.

I’ve confirmed that this is a bug in the Dynamic C 9.62 command-line compiler. The best workaround I’ve been able to find is to compile to an attached target using the “-n” command-line option for a “Null compile/syntax check without running”. If the compiler does not emit any errors, re-compile with one of the binary output options (-b, -br).

I hope that can work for your automated builds.

Thanks for your work.

I tried it and it as you suggest and it worked fine.

Pity I’ll have to compile source two times, and I’ll need an attached target, it complicates the setup.

I’ve contacted also Digi through our distributor for Rabbit products - by now seems they’re not willing to recompile dccl_cmp.exe with a fix for that. It really seems that it should be something quick to arrange… but I understand it’s an old product.


It looks like DC 9.62 was compiled over 8 years ago now, so it might be difficult to set up a development environment, locate the error and create another fully-tested release build. I’m glad there’s a workaround, but I agree that it’s sub-optimal.