Device failed enumeration on USB/2

I have an Aeon Labs Z-stick connected and then passed to win 2012 R2 server.
But i cannot get it to work, all i get in Windows is “Device Failed Enumeration”

Updated the firmware, drives and so on, Still no luck.
Is there any solution to this problem?

Have you tested this Aeon Labs Z-stick without the AWUSB, to make sure that works, providing that the issue is not with the Aeon Labs Z-stick?

Have you tried enabling the “Use Microsoft Device IDs” feature, to see if that resolves the issue? To do this, run the AWUSB Config Util (with Admin privileges), Disconnect the computer from the AWUSB, click File / Preferences, check “Use Microsoft Device IDs”, click Save, then Connect the computer back to the AWUSB.

Do you have a standard USB 2.0 hub to troubleshoot with? If so, attach it to the AWUSB (to either of the two USB ports) and then attach the Aeon Labs Z-stick to the standard USB 2.0 hub. Does the Aeon Labs Z-stick work when it’s connected this way?

The Z-stick works in my workstation with and without USB hub.

It did work before on the AWUSB and then suddenly stopped worked, Cannot find anything that has changed since then.

“Use Microsoft Device IDs” did not work, Same error.
Also did a reboot on the device without any luck.

I have another device connected to the AWUSB and that works perfect.

So quiestion is if AWUSB is to fast for the z-stick so does not have the time to initialize or something.

Good afternoon! Today, I also ran into the situation that a failed device failed enumeration, although everything worked fine. Also installed W2012R2, someone managed to solve it?