don't know what happen...

hi, i’m currently working on a project using 9Xtend 900MHz modem. my problem is that i’m trying to make 2 set of 9Xtend module talking to each other.
For my TX part my connection was (module 1):
TX PIC to DI 9Xtend
RX PIC to DO 9Xtend
GND PIC to GND 9Xtend

For my RX part, the connections what mention in the datasheet.
what happen is that, after i connected both module i don’t received anything…then i try to check (module 1) using X-CTU it show “unable to communicate with modem”… this do not happen when i check it for the first time…only module 1 that have this problem…it has happen to 2 of my module…can anyone help me on how to troubleshoot this problem??? i am eager to know is it happen and how to solved it…
do i need to connect pin 7 on both module to 5V during the transmission?


I am encountering the same problem. Any help will be appreciated.

This might not work, but have you tried shifting Di and Do connections on module 1?

I had a similar problem and I was using an FTDI to connect the UART host to the 9XTend. It was needing the opposite connections for it to work. The connections were the following:

TX FTDI to DO 9Xtend
RX FTDI to DI 9Xtend
GND FTDI to GND 9Xtend