Issue connecting to Digi Device via Ethernet

I’m having a connectivity issue with my Digi Device (PortServer TS P MEI) and I hope I can get some help.

I’ve been trying to establish an Ethernet connection, but I’m bumping the wall here. Here are the steps I’ve tried so far:

  1. Cables are good, no issues and both are securely connected on both ends.
  2. Power cycle is also working correct.
  3. I’ve verified that the IP settings on my Digi device match the network configuration.
  4. Network connectivity: I can ping the Digi device when I plug it into our network, but the device that I have connected to the PortServer doesn’t seem to be working. It’s powered on, but I can’t reach it.
  5. Tried running Digi Device Discovery and always get a message ‘No devices found’ - even I’m being able to ping it.

I’m still unable to establish a connection, I can ping the IP, which means I can find the device on the network, but I can’t find the device using discovery mode.

Anything else you guys advise that I should be looking? Any bit helps.

Thank you