my ConnectPort X4 doesn't reply to EP association beacon request


I’m using Digi’s ConnectPort X4 to act as a Zigbee coordinator and I want to connect my endpoint device to it. For the EP, I’m using a device with TI’s CC2520 and the standard Z-Stack (version 2.4.1).
I’m using a sniffer to see the messages exchanged.

The EP device is not connecting to the X4.

Using the sniffer, I can see that the EP sends the Beacon Request to join the network, but there is no response from the X4, so the association procedure is not initiated.
The devices are on the same frequency channel and are both configured to use Zigbee Pro Profile.

Here is the beacon request:

Frame 684 (Length = 10 octets)
Sequence Number: 684
Channel Sequence Number: 684
Channel: 20
Time Stamp: Tue, 04 Dec 12, 17:11:13.997
Time Delta: +00:00:01.159
Frame Length: 10 octets
Capture Length: 10 octets
Link Quality Indication: 252
Receive Power: -25 dBm
FCS: Correct (0x01)
Protocol: IEEE 802.15.4
Packet Type: Command: Beacon Request
IEEE 802.15.4
Frame Control: 0x0803
… … … .011 = Frame Type: Command (0x03)
… … … 0… = Security Enabled: Disabled (0x00)
… … …0 … = Frame Pending: No data pending (0x00)
… … …0. … = Acknowledgment Request: No ACK required (0x00)
… … .0… … = PAN ID Compression: No PAN ID compression (0x00)
… …00 0… … = Reserved: 0x00
… 10… … … = Destination Addressing Mode: Address field contains a 16-bit short address. (0x02)
…00 … … … = Frame Version: IEEE Std 802.15.4-2003 (0x00)
00… … … … = Source Addressing Mode: PAN identifier and address fields are not present. (0x00)
Sequence Number: 199
Destination PAN Identifier: Broadcast (0xffff)
Destination Address: Broadcast (0xffff)
Command Frame Identifier: Beacon Request (0x07)
FCS: 0xffff
Beacon Request

I’ve also tried other devices to join the X4 network (Digi router, Anaren EP, …) and they all connect.
I don’t understand why the X4 doesn’t reply to my device’s beacon request. Do you have any suggestions on what could be happening?



I’m still no being able to connect the two devices. As I said, the coordinator does not respond to the ZED beacon request to start the association procedure.

Assuming that the message is received correctly by the coordinator, I guess the only thing it could be happening is the coordinator discarding the beacon request message at some point: either on the MAC layer or on the NWK layer (I’m not sure if the beacon request reaches the NWK layer??).

Do you have any ideas why the MAC layer or the NWK layer of a coordinator would reject a beacon request from a ZED? Or do you think the problem could be somewhere else?

Thanks for your time in advance.



I’ve been in contact with Digi support and here is their answer:


We’ve seen this problem before. TI has a known stack issue. They apparantely haven’t corrected it across their entire product line. You’ll need to discuss the issue further with them."[/i]

Do you know anything about this supposed TI stack issue?