PortServer TS H MEI Comms

I am having a problem with establishing a TCP/IP connection from my custom software application to a PortServer TS H MEI (4-port). I stopped using my custom application and am now using HyperTerminal to troubleshoot.

I have the PortServer configured for the default socket port of 2101 and I am able to ping the IP address from a DOS command line from my laptop. However, I am not able to set up a HyperTerminal session using TCP/IP (Winsock) specifying the configured IP address and port 2101. I have a cross-over cable connected between my laptop and the PortServer with the PortServer and laptop IP addresses being on the same network.

I have turned off my Windows XP firewall and still cannot establish a HyperTerminal session. I am at a loss to understand why I cannot connect. I even disconnected my serial device from the serial port of the Digi and installed the loopback connector on the Digi serial port but no success. Help!!

Followup to my previous posting. I forgot to mention a very importnant point - I had previously tried another laptop and all comms and my custom application worked fine on that laptop so I am suspecting something on my second laptop is the problem, I just can’t figure out what it could be and where I need to start looking.

Hi Isaac,

Yes that is a very important bit of information.
Some software firewalls are installed as part of an antivirus program, so you may wish to temporarily disable it if you have one running. Symantec’s products, Zonealarm, etc., may interfere.

I assume you are also using the same ethernet cable which worked with the other laptop.

Are you able to log into the Digi with your browser?
If yes, you may wish to check the connections. Under Management, Connections, are there any active connections?
If the Digi thinks a previous connection is still up and valid, it won’t let you establish a new connection to the serial port (assuming port sharing is not enabled). If this is the case, you can “disconnect” the connection and then re-establish a connection with Hyperterminal.

Thanks async-man,

Turns out that the PortServer had lost its serial port settings. I reset them and kept noticing later that they had again changed.

I sent an email to Digi TechSupport and following is the reason they gave me for the serial port settings being changed.

“You may wish to set the option in the device manager->multiport serial adapters->PortServer->properties->Advanced->Properties->select port 1->select the Advanced tab-> and check the box for ‘Do Not Scan Modems on Boot etc.’ Windows may be periodically scanning the com ports checking if modems or serial mice are attached. It resets the port parameters when it does this. This may be the reason your port settings are getting changed.”

Thanks for your suggestion on checking the Anti-Virus software. I had not thought of that before and I’ll definitely keep it in mind for future troubleshooting. I did disable it after I received your email but it had no effect and finally I checked the serial port settings of the PortServer again and noticed the Serial Port settings had changed and thus the real reason for the problem being unable to communicate.