Problems getting started with StarterKit (XBee PRO S2B)


I’m completely new to XBee. I got the Starter Kit including two Boards and two XBee Pro S2B - Modules.

I installed X-CTU and the Drivers as mentioned in the manual. Unfortunately whether the “PC Settings -> Test / Query” works, nor does “Modem Configuration -> read”.

“Test / Query” throws the Dialog in the attached Image.
(Modem type = Name unknown (SERIAL), Firmare = @||$y…)

“Modem Settings -> read” returns “The Modem configuration file was not found. Would you like…” If I hit “Yes” some files are downloaded, but afterwards a dialog appears, telling me “Modem configuration file not found after update”.

I tested both boards and both XBees, but the results are equal, not matter what I do.

I even tested each single baud - without any success.

Is there anyone who can help me?



Is there really no one that can help me with this problem? :frowning:

My initial “knee Jerk” reaction is that you do not have the Baud rate set properly on your port. Default is 9600 Baud. I would try that baud rate first and then if you still have issues, reflash the radio to the newest Firmware and or then try again using default baud rates. That should solve the strange characters issue when you do the Test Query. Note that if you get strange characters when doing a Test Query doing a read will not help at all. If it gets garbage it simply dumps the data and does nothing, I.E. you get a blank screen.

Thanks for your reply!
First of all I used the correct baud rates (I even tried each single one…) and none is working.

I did not try your second solution yet, because of being a little scary about pluggin a module into a powered board…

Another interessting point is, that I receive a row of red dots in the Terminal window, when I try to enter ByPass mode at baud 115200 (to flash new firmware).

If I change to ByPass mode at 9600 the “CTS”-field gets green, but I’m still not able to write a firmware onto the module… similar to when I try to"read", it tells me “Action required - Unable to communicate with modem” :confused:

If I open “Modem Configuration” and then “Remote Configuration…” I can choose a Module and read Firmware - unfortunately I cannot write on it :frowning:

I am also still not able to read firmware or Test/Query the Modules.

With the XStick everything works fine…

I managed to change Scan Channel and write this change on one module :slight_smile:

Well you would get fed up with the garbage data while running a Test Query…That is really worse!!

Hi there,

Since this is failing even with PC Settings’ Test/Query, it sounds to me like the drivers haven’t installed properly for the board you’re using.

When you pop open XCTU on the PC Settings tab, you’ll see some com ports listed. One of these may be a built-in com port on your motherboard (less common these days) but another you see should be for your board. Look this same com port up in Device Manager and see if there’s a ? indicating a driver issue. If so, check the Support website for correct driver (if board is Digi XBIB, check manufacturer if other), download to your hard drive and upzip, in Device Manager do the “Update Driver” process, and point back to where you unzipped this.

Hopefully your issue would be resolved at that point, and a PC Settings Test/Query to the port with a connected board and properly seated module would succeed.

(you can swap the modules while the board is running by the way, done it many times and never had a problem…)

The XCTU ‘test/query’ often fails if the baud rate and API mode in XCTU doesn’t match that in the XBee. XCTU does some minor probing to try and find a mismatch, but it does not try very hard.

So never assume the Xbee is dead just because ‘test/query’ fails.