Putting the XBee pro into bootload mode

has anyone tried to put custom firmware onto the Xbee pro
by putting it into bootload mode? I’m having difficultly
getting it into the bootload mode.

there are steps on how to do this in the manual(pg 140)

Here’s what I have =>

  • XBIB-U-DEV rev 3 development board
  • XBee PRO S2 module
  • hyperterminal configured as(baud - 115200, stop bit - 1, flow
    control - hardware, parity - none, data bit - 8)

Here’s what I’ve done =>

  • jumpered pin 9 (DTR) to ground
  • jumpered pin 16 (RTS) to Vcc
  • sent a serial break (ctrl+break) through hyperterminal
  • pushed reset button on the dev board
  • terminated the break by pushing the enter key.

even after all this, i still dont see the bootload menu

I know nothing at all about bootload mode, but 115,200 baud can be problematic with any XBee if you’re not careful. So my suggestion would be to try this at a lower baud rate, in order to eliminate that possible issue.

A question: which manual are you referring to? You refer to page 140, yet my copy of the ZNet2.5 manual (which is the one that applies to this forum) only goes up to page 90.

You can enter the bootloader by using the terminal tab of the X-CTU and the following steps:

Enable hardware flow control on the PC settings tab
On the terminal tab, de-assert the DTR and enable Break
Send a at 115.2kbps
Hit the reset on the interface board
remove the break and change to 38,400 bps.

the XBee/XBee PRO ZB RF modules. you can get it off of the digi webiste - 90000967_F.pdf

thanks mvut. I enabled hardware flow control on the PC settings tab. i also de-asserted the DTR and enabled Break. but how do you send the on the terminal tab??

You click on the terminal screen and hit your Enter key.

ok. i still dont see the bootload menu.

Then the bootloader has been over written on your module.

Here is how to do this on the ZB module using the X-CTU. I am simply following the directions in the ZB product manual.

Read your radio in the Modem Configuration tab. set the BD parameter to 7 - 115200 (this is necessary as the bootloader communicates at this rate, and no there is no issue with this baud rate on this chip. That only applies to the 802.15.4 module)

Click Write to store the parameter value.

In the PC Settings tab, set the baud rate to 115200 to match.

Disable hardware flow control, do this by setting Flow Control to NONE in the PC Settings tab.

Click to the Terminal tab.

Uncheck the RTS box.

Check the Break box.

Click the Reset button on your Digi Interface board.

Uncheck the Break box.

Click in the terminal tab and press the Enter key.

The bootloader menu will display on the Terminal.

thanks buddy, that worked.

Ah - I see from gworle’s comment that I’ve been feeding false info about the 115200 baud rate. Presumably the series 2’s have a higher clock rate than the series 1’s - anyway I’ve taken the point and thanks gworle for the correction.