RCI-Serial on connect devices

Having some problems with RCI over serial.
I see in the forums alot of unanswered questions about this.

I set DSR, send an XML string, and get back NOTHING until I release DSR, where I immediately get back :

(no matter what I send to it)
at 9600 bps.

What am I missing ?


Hi Glen

The RCI manual is not the best, it is missing some information and also misleading.

DSR is low active.

The module will send the

and try this line

when you send try it this way:

Let me know if that helps


can you please help me find actual documentation. I am unable to discover the proper manual for rci over serial with digi connect ME devices.

Jan Kraus
R&D - Power Quality Metters

I hava a CPX4 gateway and I want to use the RCI over serial. I have activated RCI over Serial (DSR) in the Serial Port Configuration. But when I send a following message to the serial port:

The gate replies:

error: command not found
type ? for help

I have tried with DSR High or Low but same error. AM I missing something?

The CLI (term) has control of the serial port. You must turn it off. I would have thought what you did in the Serial Port Configuration would have automatically turned it off, but you made just need to reboot the device. Also to make sure term is off, from the CLI:
#> set term port=1 state=off

Then reboot device, and RCI serial should now work.