Starter kit problems

Trying the starter kit with ConnectPort X and two xbee sensor adapters. When I first connected everything, the connect port could see both adapters. Then I changed the PAN ID for the connectport, which caused it to lose connectivity with both adapaters. Tried changing the ConnectPort PAN ID back to 234, but it wasn’t able to reestablish visibility. Tried pressing the ident button on the adapters, but it doesn’t seem to do anything. Swapped the Xbee module inside one of the adapters, but there was no change. Tried a factory reset of the ConnectPort, but there was still no change.

Is there some trick I’m missing?

What’s the correct way to change the PAN ID for an adapter?


It sounds like when you changed the PAN ID on the gateway, it also changed the channel, so although your adapters and the gateway are on the same PAN ID they might not see each other due to this.

If you’re trying to put the adapters/gateway on a different PAN ID, the way to do this would be to change the adapters to a different PAN ID first via the ConnectPort X configuration > Mesh Networking screen. Once the other adapters are on the new PAN ID, you’d then change the ConnectPort X over to the same PAN ID, and everyone should see everyone.

As far as going forward, currently there isn’t a way to reset the adapter other than re-loading the firmware via the X-BIB board, which resets them to factory default and will allow them to re-establish communication with the ConnectPort X.

There is an upcoming firmware release that will work the way you attempted, pushing the reset button 4 times will reset the adapter without having to reload the firmware.

So do you think if I manually set the gateway to each channel and tried the discovery process that I would eventually find the adapters?

I will also try reloading the xbee modules by taking them out and putting them into the x-bib and doing a firmware download.

During the “drop in” web presentation, I thought they said the system scans the channels for the lowest energy, then picks that channel, and can also automatically move channels later if it detects new interference? I guess I’m confused about how the adapters got to a channel now where the gateway can’t find them. At startup, I guess the gateway and adapters were on the same PAN ID and the same channel. Then the gateway coordinated them to move to a better channel, and that’s where they are now?


I actually was able to get them back by repeatedly changing the PAN ID on the gateway between x0234 and a random ID. Each time I switched back to 0x0234, I would do a discovery and eventually the gateway picked channel 13 again, and found the adapters…

Thanks for the update and I’m glad you got it resolved. I believe the next version of firmware will address a lot of these “types” of issues with discovery etc. I can’t give a timeline when that firmware will be out, but I know its being tested right now so it shouldn’t be too much longer.