TS4 autoconnect telnet problems

Has anyone encountered the following behavior?

When ports are configured as autoconnect to telnet into a unix host, running the ‘who’ command displays either of the following 3 results under the ‘Connected to’ column:

  1. the correct destination IP address
  2. nothing at all
  3. garbage characters

The first case occurs the least. Also the number under the sessions column is sometimes unrealisticly high (ie: 1134617) although not always the same number.

As well, if I run the kill command ‘ie kill tty=4’ while a port is listed by ‘who’ causes the TS4 to reboot.

firmware: 82000716_J

ports setup as follows:

set port ra=1-4 dport=23 dest= auto=on
set flow ra=1-4 altpin=on
set port ra=1 termtype=~001
set port ra=2 termtype=~002
set port ra=3 termtype=~003
set port ra=4 termtype=~004

I’ve been using this setup for a couple of years now on both the TS4 and TS16.

The reason for the wierd termtype is that I’m using the passed termtype that sets $TERM to uniquely identify the source TS port. I then detect the actual terminal type later. This behavior exists regardless of whether I have the termtype set or left at default.

BTW, before anyone suggests that I use Realport, I gave it up a couple of years ago because the dgrp module needed unloading whenever a single port got bunged up and restarting realport to the portserver wouldn’t clear up the problem. Before I could unload the dgrp module I had to kick users off of other TS that were having no problems. They weren’t happy.

I’m having the exact problem using a TS4 with wy60-25 Termtype. I’ve opened a case with their support and waiting on a response. The TS8-TS16’s work fine with the same settings.

You gave me the idea of trying with a blank terminal type, and my TS4 seems to be behaving now, I then set it back to the default vt100 and it’s still ok, then I went to my ~### terminal type and still ok. Seems kind of odd to me that clearing the terminal type out would fix the problem.

Try it out and let me know if you get the same results.

As for myself, I’m still going to play around with it and wait for the problem to return, I may just be on a lucky stretch.