unable to communicate with the modem

i m using two xbee series 2 modules. one of them mounted on the explorer n other on arduino mega 2560 through a xbee shield. i was successful in establishing a two way communication between the two,but today all of a sudden when i ran the test query i got an error msg saying unable to communicate with the modem.
baud rate:9600
flow control: none
data bits :8
stop bits:1
r the specifications
i need serious help!!!


What is the firmware on the modules?
Try to reflash the firmware on the modules, use the below steps.

  • Select Correct Modem, Functional set and Vesrion
  • Click “Show Defaluts”
  • Enable “Always Update Firmware” checkbox
  • Click Write
  • If the Action required window pops up, press the reset button on the development boards.

This is just more of what 16ksa23 is saying but:

Just pulling the modems up in X-CTU may give you an idea of what is going on. If that doesn’t work:
Optimize your USB to Serial Port Settings and
Follow this XBEE recovery procedure

If it fails again more details of what happened when they failed and what settings you are using would be great.

1 Like

Hello Shweta,

The recovery method will not be successful if you try to do it using the Arduino with shield. You MUST use the Explorer board. The Shield doesn’t have all the right lines connected for module recovery.

thanks… it worked…

ya i used the explorer board

You can use Digi boards,