Xbee Pro s3B - unable to configure in X-CTU and getting weird message while query modem

Hi everyone!

i’m using a gravitech 3.3v adapter for my xbee pro s3b…
the problem that i have is that when testing/query modem i get weird information

see link for more info…


i did read the issue for 3rd party adapters and i did remove the RSSI Resistance in my adapter…

it is really weird because sometimes i can read the modem and configure it… but most of the time cant configure it …

i need help! …

1 Like

I’m going to assume you don’t see this error if the module is placed on the digi prototype board.

have you seen the section in the hardware guide talking about power supply? (pg. 14-):

1 Like

hey thanks for answering …

I don’t have the digi prototype board… i am using Gravitech 3.3V Adaptor… to configure the module… sometimes i can access the modem without problems but most of the time i cant :S

I’ve seen situations where the module and the board don’t get along as far as power settings. I remember one time a board was ramping the voltage up too quickly (0-3.3v in 10 micro seconds). The module (not an xbee) required a time between 700 micro - 140ms, so it was way out of range. The module booted in an unknown state and would act unpredictable.

1 Like

so the solution for my problem would be to change the adapter? … because i’m making tests with arduino but can get them to communicate :S

I would try something different, just to get another data point. Perhaps another Xbee will work, though I’d be surprised if that’s the solution. More likely there is some kind of hardware incompatability.

I know this, if you drop the xbee on the digi prototype board, it will work. we tell customers that all the time when they have problems like yours.

when you get the error, what is the red LED on the module doing? blinking?

Yes exactly…

right now i was able to configure it … now im just trying to send characters through arduino …

do you think i’ll be having the same problem communicating with an xbee router ???

Try to reflash the firmware using below steps

  • Change the baud rate to 38400 and check “No baud change” under PC Settings in X-CTU
  • Go to Modem Configuration tab, select correct Modem, Function set and Version
  • Click “Show Defaults”
  • Check “Always Update Firmware”
  • Click “Write”
    If “Action Required” window pop up, press the reset button on the interface board once, Digi interface provides reset button.
    I’m not sure about other boards. The pop up disappears and module gets programmed to selected firmware.
  • If you get any errors, like checksum error failed, you need to optimize your interface boards, refer the following link, http://www.digi.com/support/kbase/kbaseresultdetl?id=3418
  • Now go to PC Settings and change the baud rate to 9600 and uncheck “No Baud Change”
  • Go to modem configuration tab and select Read, you can see all the XBee parameters.

Thank you!! i’m considering getting the Digi adapter but im not sure wich one i need… which do you recommend?