Xbee wifi s6b not receiving API frames in Ad-hoc mode

I am using two xbee wifi s6b modules with the 2026 firmware. I am able to connect both the modules in adhoc mode from the steps as show in the documentation. Further, I am also able to get them to communicate in the transparent mode. However, they do not seem to receive frames when configured in the API mode. How can I get them to communicate in the API mode, any ideas? I can’t pin point a parameter that might affect such a selective behavior by the modules.



Do you have API mode enabled and are you monitoring port BEE?

Hi mvut,

I just resolved it. Since I am working through the serial port I am not using port BEE. Instead for TCP I set my source port number to 0. That helped me get the API frames going. It was a silly error, thought I would not make such a mistake, but then that was the issue.

Thanks again!